Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Marketplace don't start
Marketplace don't start [message #1853341] Tue, 28 June 2022 13:23 Go to next message
Liès TIGUERCHA is currently offline Liès TIGUERCHAFriend
Messages: 2
Registered: June 2022
Junior Member
Hello everyone ! :)

I'm having some issues with Eclipse Marketplace. I tried to search some responses but can't find anything relevant for my problem. I tried changing the network connections, adding certifications... Nothing solves it.
Here's the error:

MarketplaceDiscoveryStrategy failed with an error
Cannot complete request to https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&os=win32&platform.version=4.23: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

Hope someone will be able to help me :)
Thanks !
Re: Marketplace don't start [message #1853347 is a reply to message #1853341] Tue, 28 June 2022 17:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32660
Registered: July 2009
Senior Member
Are you inside a corporate firewall? In my experience, this type of error is always caused by missing root certificate in the certificate store. You could try the option mentioned in this comment:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=567504#c28


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Marketplace don't start [message #1853364 is a reply to message #1853347] Wed, 29 June 2022 10:00 Go to previous message
Liès TIGUERCHA is currently offline Liès TIGUERCHAFriend
Messages: 2
Registered: June 2022
Junior Member
Ed Merks wrote on Tue, 28 June 2022 17:54
Are you inside a corporate firewall? In my experience, this type of error is always caused by missing root certificate in the certificate store. You could try the option mentioned in this comment:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=567504#c28


Yeah I was inside a corporate firewall. I'm now at my home and you're right it's working. But at work it doesn't. I'll try your solution when at the office and will reply back if it is working.

Thank you by the way !
Previous Topic:Retrieve User Name and Email Address from the Git Repo
Next Topic:obscuration to peruse through a VPM like TOR?
Goto Forum:
  


Current Time: Tue Jan 31 08:19:47 GMT 2023

Powered by FUDForum. Page generated in 0.07107 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top