Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » e(fx)clipse » Launching e(fx)clipse RCP for Java17(Problem launching e(fx)clipse RCP for Java17)
Launching e(fx)clipse RCP for Java17 [message #1851622] Mon, 11 April 2022 12:29 Go to next message
Marco Maisano is currently offline Marco MaisanoFriend
Messages: 22
Registered: March 2020
Junior Member
Hi,

using:
- Eclipse 2021-12
- Java JDK 17
- JavaFX SDK 11

and following the following guide: https://tomsondev.bestsolution.at/2020/01/28/setting-up-efxclipse-rcp-development-for-java11-and-pde/

So summarizing the steps:
1) I have installed the Java17 JDK.
2) Link the JavaFX sdk
3) Set the Target Platform with the 2 software sites
- http://download.eclipse.org/efxclipse/runtime-latest/site
- http://downloads.efxclipse.bestsolution.at/p2-repos/openjfx-17.0.1/

4) Setted the feature with application and org.eclipse.fx.osgi
index.php/fa/41909/0/

5) Setting the product content with:
- feature
- org.eclipse.fx.runtime.e4fx.feature
- openjfx.standard.feature

Then, I created into the Application.e4xmi a TrimmedWindow with a Part like in the guide....

Then, launching the product I have the following problem:

WARNING: Using incubator modules: jdk.incubator.foreign, jdk.incubator.vector
!SESSION 2022-04-11 12:50:01.804 -----------------------------------------------
eclipse.buildId=unknown
java.version=17.0.1
java.vendor=Eclipse Adoptium
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_GB

!ENTRY org.eclipse.osgi 2 0 2022-04-11 12:50:01.994
!MESSAGE The persistent format for the framework data has changed. The framework will be reinitialized: Found persistent version "6" expecting "3"

!ENTRY org.eclipse.osgi 4 0 2022-04-11 12:50:01.996
!MESSAGE The -clean (osgi.clean) option was not successful. Unable to clean the storage area: C:\Marco\ELMAN\Workspace\2022-04-dev3.0\.metadata\.plugins\org.eclipse.pde.core\my.app.app.product.product\org.eclipse.osgi

!ENTRY my.app.app 4 0 2022-04-11 12:50:02.356
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: my.app.app [8]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=17))"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1634)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1613)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1585)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1528)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.app 0 0 2022-04-11 12:50:02.542
!MESSAGE Product my.app.app.product could not be found.

!ENTRY my.app.app 2 0 2022-04-11 12:50:02.582
!MESSAGE Could not resolve module: my.app.app [8]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=17))"


!ENTRY org.eclipse.osgi 4 0 2022-04-11 12:50:02.583
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:77)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:568)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)
gogo: InterruptedException: sleep interrupted
java.lang.InterruptedException: sleep interrupted
at java.base/java.lang.Thread.sleep(Native Method)
at org.apache.felix.gogo.shell.Activator.run(Activator.java:72)
at java.base/java.lang.Thread.run(Thread.java:833)

Can someone help me?

[Updated on: Mon, 11 April 2022 12:30]

Report message to a moderator

Re: Launching e(fx)clipse RCP for Java17 [message #1851646 is a reply to message #1851622] Mon, 11 April 2022 16:36 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6648
Registered: July 2009
Senior Member
This line is causing the problem
 Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=17))"


The runtime shipped by efxclipse does not know Java-17. Please lower that to 11 for the moment.
Re: Launching e(fx)clipse RCP for Java17 [message #1851668 is a reply to message #1851646] Tue, 12 April 2022 07:46 Go to previous messageGo to next message
Marco Maisano is currently offline Marco MaisanoFriend
Messages: 22
Registered: March 2020
Junior Member
Ok,
now using:
-efxclipse 3.7.0
- Adopt JDK 11
- JavaFX 11

and followinf the tutorial step by step, I still have the same problem regarding osgi.ee on version 11...

org.osgi.framework.BundleException: Could not resolve module: my.app.app [8]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1634)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1613)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1585)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1528)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.equinox.app 0 0 2022-04-12 09:42:52.324
!MESSAGE Product my.app.app.product could not be found.

!ENTRY my.app.app 2 0 2022-04-12 09:42:52.382
!MESSAGE Could not resolve module: my.app.app [8]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"


!ENTRY org.eclipse.osgi 4 0 2022-04-12 09:42:52.383
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:596)
at org.eclipse.equinox.launcher.Main.run(Main.java:1467)
at org.eclipse.equinox.launcher.Main.main(Main.java:1440)
gogo: InterruptedException: sleep interrupted
java.lang.InterruptedException: sleep interrupted
at java.base/java.lang.Thread.sleep(Native Method)
at org.apache.felix.gogo.shell.Activator.run(Activator.java:72)
at java.base/java.lang.Thread.run(Thread.java:829)
Re: Launching e(fx)clipse RCP for Java17 [message #1851669 is a reply to message #1851668] Tue, 12 April 2022 07:54 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6648
Registered: July 2009
Senior Member
are you really running on Java-11 - please note I didn't say you need to run on Java-11
Re: Launching e(fx)clipse RCP for Java17 [message #1851671 is a reply to message #1851669] Tue, 12 April 2022 08:03 Go to previous messageGo to next message
Marco Maisano is currently offline Marco MaisanoFriend
Messages: 22
Registered: March 2020
Junior Member
Then, according on your answers, what should I reduce from java17 to 11?
Can you explain to me in more detail?

Thanks
Re: Launching e(fx)clipse RCP for Java17 [message #1851674 is a reply to message #1851671] Tue, 12 April 2022 10:08 Go to previous messageGo to next message
Thomas Schindl is currently offline Thomas SchindlFriend
Messages: 6648
Registered: July 2009
Senior Member
well the OSGi tells you that the bundle requires at least Java-11 but it looks like your are not launching the application on a Java-11 JRE/JDK - so what is the version you are launching your application with?
Re: Launching e(fx)clipse RCP for Java17 [message #1851676 is a reply to message #1851674] Tue, 12 April 2022 10:34 Go to previous message
Marco Maisano is currently offline Marco MaisanoFriend
Messages: 22
Registered: March 2020
Junior Member
1) Installed JREs:
index.php/fa/41917/0/

the default is 11.0.13

2) Run Configuration:
index.php/fa/41918/0/

3) System Library
index.php/fa/41919/0/

4) Compiler:
index.php/fa/41920/0/

as you can see, the compliance is always set for java 11...
  • Attachment: Immagine 2022-04-12 122638.png
    (Size: 55.83KB, Downloaded 136 times)
  • Attachment: 1.png
    (Size: 8.57KB, Downloaded 137 times)
  • Attachment: 2.png
    (Size: 15.91KB, Downloaded 133 times)
  • Attachment: 3.png
    (Size: 64.86KB, Downloaded 132 times)
Previous Topic:openjfx plugins on aarch64
Next Topic:Unable to instantiate class that extends FXViewpart
Goto Forum:
  


Current Time: Mon Oct 03 00:55:11 GMT 2022

Powered by FUDForum. Page generated in 0.03153 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top