Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » syntax coloring not working correctly(syntax coloring not correct on some projects)
syntax coloring not working correctly [message #1851236] Thu, 31 March 2022 14:02 Go to next message
Bob Ansay is currently offline Bob AnsayFriend
Messages: 3
Registered: March 2022
Junior Member
Hi all,

I've been using eclipse for a while but would say I'm still a beginner ;)

I use sloeber, a eclipse plugin for Arduino development.

Recently I imported a project via git (don't know whether that is important) and the syntax coloring is not complete, only parts of the source code are correctly displayed

I am not allowed to link external images, so please find them in the attachement

I checked project natures and they are identical

I think it is an indexing problem, because features like "go to declaration" don't work either

Any idea on where I should look to get this right again?
  • Attachment: right.png
    (Size: 42.54KB, Downloaded 82 times)
  • Attachment: wrong.png
    (Size: 42.72KB, Downloaded 73 times)
Re: syntax coloring not working correctly [message #1851245 is a reply to message #1851236] Thu, 31 March 2022 16:57 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4267
Registered: July 2009
Senior Member

Sloeber is a third-party plug-in not provided from eclipse.org. You should start in its
forums and check its issue tracker.


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: syntax coloring not working correctly [message #1851266 is a reply to message #1851245] Fri, 01 April 2022 06:48 Go to previous messageGo to next message
Bob Ansay is currently offline Bob AnsayFriend
Messages: 3
Registered: March 2022
Junior Member
I came here on purpose, because I thought that this is a thing that is controlled by the underlying eclipse components like indexer and syntax coloring...
Was that the wrong approach?
Re: syntax coloring not working correctly [message #1851267 is a reply to message #1851266] Fri, 01 April 2022 07:32 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
Generally each technology provides preferences for its syntax highlighting which you will find in Window -> Preferences -> General -> Appearance.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: syntax coloring not working correctly [message #1851511 is a reply to message #1851267] Thu, 07 April 2022 08:13 Go to previous messageGo to next message
Bob Ansay is currently offline Bob AnsayFriend
Messages: 3
Registered: March 2022
Junior Member
Thanks,

but the issue here is that the syntax highlighting will only take place halfway as shown in the screenshots.

I have been playing around a lot and found that reverting to a backup of the project restored correct syntax highlighting.
The newly imported project (from git) had the describes issue.
And I have a newly created project that "references" the above mentioned code files which also has the same issue.

Is it possible that the faulty syntax coloring has to do with either of these two (git import and only linked files)
Re: syntax coloring not working correctly [message #1851513 is a reply to message #1851511] Thu, 07 April 2022 08:38 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
I'm not sure anyone here can theorize what might be going wrong. Perhaps the path for finding included files has changed such that it doesn't find them and then doesn't colorize what should be links...

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Is Java tool mandatory to use Eclipse and eclipse works on Citrix server ?
Next Topic:Unable to connect to Eclipse Marketplace
Goto Forum:
  


Current Time: Thu Oct 06 04:12:47 GMT 2022

Powered by FUDForum. Page generated in 0.02919 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top