Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Update failed(No Startup after update 2021-12 -> 2022-03)
Update failed [message #1850860] Fri, 18 March 2022 17:25
Christoph Fetzer is currently offline Christoph FetzerFriend
Messages: 1
Registered: March 2022
Junior Member
Hi!

I am new to this forum. No idea, if I'm posting at the right place. If not, just please point the right direction.

Here my issue:

Basically I was running a CDT installation of 2021-12 on Windows 10 but added a lot of plugins on top of that:
xml-plugins
RED-plugin for work with robotframework
jenkins-file editor
jira connector
jenkins-connector
CVS-plugin (that used to be external for a while - don't have in mind if it's integrated again or not)
I don't have everything in mind.

Yesterday an update-notification to version 2022-03 popped up, I confirmed, got no failure during the update, was asked for an eclipse restart and after that I got a failure "An error has occurred, See the log file blablabla.log"

That log showed something like
"!SESSION 2022-03-18 18:08:08.793 -----------------------------------------------
eclipse.buildId=4.23.0.I20220308-0310
java.version=11.0.10
java.vendor=Azul Systems, Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Framework arguments: -product org.eclipse.epp.package.cpp.product
Command-line arguments: -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.cpp.product

!ENTRY ar.com.tadp.xml.rinzo.core 4 0 2022-03-18 18:08:09.829
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: ar.com.tadp.xml.rinzo.core [3]
Unresolved requirement: Require-Bundle: org.eclipse.ui

at org.eclipse.osgi.container.Module.start(Module.java:463)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1847)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1840)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1781)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1745)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1667)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)

!ENTRY ar.com.tadp.xml.rinzo.jdt 4 0 2022-03-18 18:08:09.829
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: ar.com.tadp.xml.rinzo.jdt [4]
Unresolved requirement: Require-Bundle: org.eclipse.jdt.core
"

By using google I found a hint to use eclipse -clean.
After ttrying that, the basic content of the log changed and is now the one shown above.
Also some other names appear like
com.atlassian.connector.eclipse.bamboo.core
org.eclipse.mylyn.commons.core
com.atlassian.connector.eclipse.bamboo.ui

Do you have any idea for me how to proceed from here? Is there a way to start up in a "clean mode" (without any plugin) where I could disable the plugins step by step until it starts up again? Or a configuration that works similar?
Or a documentation that explains how to do that (without the need to dig into down to eclipse plugin developer level)?

Any advice would be highly appreciated!

Best regards,
Christoph


Previous Topic:CDT cant generate obects
Next Topic:Java stack overflow error
Goto Forum:
  


Current Time: Mon Jan 30 19:17:59 GMT 2023

Powered by FUDForum. Page generated in 0.08391 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top