Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to connect Eclipse Marketspace(Unable to connect Eclipse Marketspace)
Unable to connect Eclipse Marketspace [message #1850630] Fri, 11 March 2022 03:42 Go to next message
Riaaz Shaik is currently offline Riaaz ShaikFriend
Messages: 2
Registered: March 2022
Junior Member
I am unable to connect Eclipse Marketspace using Neon 3.0.
Here is the error message. How do I fix this ?

MarketplaceDiscoveryStrategy failed with an error
Cannot complete request to https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&client.version=1.5.4.v20170222-1921&os=win32&ws=win32&nl=en_US&java.version=1.8.0_131&product=org.eclipse.epp.package.jee.product&product.version=4.6.3.M20170301-0400&runtime.version=3.12.0.v20160606-1342&platform.version=4.6.3.v20170301-0400: Unable to read repository at https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&client.version=1.5.4.v20170222-1921&os=win32&ws=win32&nl=en_US&java.version=1.8.0_131&product=org.eclipse.epp.package.jee.product&product.version=4.6.3.M20170301-0400&runtime.version=3.12.0.v20160606-1342&platform.version=4.6.3.v20170301-0400.
Unable to read repository at https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&client.version=1.5.4.v20170222-1921&os=win32&ws=win32&nl=en_US&java.version=1.8.0_131&product=org.eclipse.epp.package.jee.product&product.version=4.6.3.M20170301-0400&runtime.version=3.12.0.v20160606-1342&platform.version=4.6.3.v20170301-0400.
sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Re: Unable to connect Eclipse Marketspace [message #1850631 is a reply to message #1850630] Fri, 11 March 2022 04:36 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4267
Registered: July 2009
Senior Member

That's usually the fault of an outdated O.S. or Java runtime, incapable of handling newer certificates properly. Which versions of each
are you on? For the Java version, be sure to pay attention to the patch level as well.


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Fri, 11 March 2022 04:37]

Report message to a moderator

Re: Unable to connect Eclipse Marketspace [message #1850633 is a reply to message #1850631] Fri, 11 March 2022 05:31 Go to previous messageGo to next message
Riaaz Shaik is currently offline Riaaz ShaikFriend
Messages: 2
Registered: March 2022
Junior Member
Thank you for the swift response.
I am using Windows 10 Enterprise v20H2 and my Java version is as below:
java version "17.0.2" 2022-01-18 LTS
Java(TM) SE Runtime Environment (build 17.0.2+8-LTS-86)
Java HotSpot(TM) 64-Bit Server VM (build 17.0.2+8-LTS-86, mixed mode, sharing)

It seems I am already using latest Java.
Re: Unable to connect Eclipse Marketspace [message #1850652 is a reply to message #1850633] Sat, 12 March 2022 08:32 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32506
Registered: July 2009
Senior Member
I didn't think that Neon can run with Java 9 or higher. Are you sure this is the JVM actually being used by your IDE? I suppose there is a good reason why you are suck on Neon? Does your eclipse.ini have a -vm specified that's perhaps using a different (Java 8) JVM?

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Newer Version of any Eclipse wont start
Next Topic:Login id for this website
Goto Forum:
  


Current Time: Thu Oct 06 04:15:31 GMT 2022

Powered by FUDForum. Page generated in 0.04705 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top