Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Installation of older SDK Versions broken(Installation of older SDK Versions broken)
Installation of older SDK Versions broken [message #1850449] Thu, 03 March 2022 12:47 Go to next message
Christoph Holter is currently offline Christoph HolterFriend
Messages: 3
Registered: February 2022
Junior Member
Hi,

since the release on Monday of 2.26 I'm experiencing that all older SDK-Versions available on the P2-Update-Site are broken.
A clean eclipse installation of 2020-03 is either frozen at the splash screen after installation of 2.23 - 2.25 or throwing a lot of exceptions regarding missing mwe2 plugins.

Did you change anything regarding the older versions in the p2-update sites when releasing 2.26?
Is anybody else experiencing these problems?
Re: Installation of older SDK Versions broken [message #1850452 is a reply to message #1850449] Thu, 03 March 2022 13:08 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14353
Registered: July 2009
Senior Member
i have not seen anything like that. can you provide jstacks? how do you install the older versions?
which mwe and xtext versions end up in the installation?
do you use composite update site or rel specific

https://download.eclipse.org/modeling/tmf/xtext/updates/releases/2.25.0/


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Thu, 03 March 2022 13:22]

Report message to a moderator

Re: Installation of older SDK Versions broken [message #1850453 is a reply to message #1850452] Thu, 03 March 2022 13:37 Go to previous messageGo to next message
Christoph Holter is currently offline Christoph HolterFriend
Messages: 3
Registered: February 2022
Junior Member
I'm installing the 2020-03 Eclipse IDE for Eclipse Committers using the Oomph Installer and then try to Install XText 2.23 Complete SDK using the "Install new SW" Function within eclipse by adding the XText-Update Page (https://download.eclipse.org/modeling/tmf/xtext/updates/composite/releases/).
I added a log and and JStack-Dump from my frozen eclipse. According to the log some of the xtext jars seem not to be available and therefore the eclipse freezes (I guess). But I don't understand why the files are not available anymore as I'm not using a proxy or anything similar that could block the download, so actually it can be just an issue of the update site
  • Attachment: .log
    (Size: 102.83KB, Downloaded 25 times)
  • Attachment: jstack.txt
    (Size: 16.14KB, Downloaded 23 times)
Re: Installation of older SDK Versions broken [message #1850454 is a reply to message #1850453] Thu, 03 March 2022 13:58 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 14353
Registered: July 2009
Senior Member
can you please try the non composite update site and add the 2.25 and mwe 2.12.1 update sites individually

and/or select xtext 2.25 & mwe(2) 2.12.1 explicitely


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de

[Updated on: Thu, 03 March 2022 13:59]

Report message to a moderator

Previous Topic:Generate correct code in xtend
Next Topic:From custom types to Java types
Goto Forum:
  


Current Time: Mon Oct 03 02:37:01 GMT 2022

Powered by FUDForum. Page generated in 0.02515 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top