Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Not able to import a war file in Eclipse 2020-06.(Not able to import a war file in Eclipse 2020-06, Throws error just at start of the import.)
Not able to import a war file in Eclipse 2020-06. [message #1849595] Wed, 26 January 2022 13:18 Go to next message
Jiten Panna is currently offline Jiten PannaFriend
Messages: 2
Registered: January 2022
Junior Member
Hi,

I am working on a project which created a war.
While I try to import this war I get the below error.
I have checked the -vm to point to Open JDK 1.8.
This same war , I am able to import in other Eclipse Neon without any issue.
The error is :
org.eclipse.core.commands.ExecutionException: Error importing Module File
at org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.doExecute(J2EEArtifactImportOperation.java:89)
at org.eclipse.jst.j2ee.internal.web.archive.operations.WebComponentImportOperation.doExecute(WebComponentImportOperation.java:70)
at org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.execute(J2EEArtifactImportOperation.java:57)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl$1.run(DataModelPausibleOperationImpl.java:385)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2292)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2317)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:410)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:360)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.doExecute(DataModelPausibleOperationImpl.java:247)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.executeImpl(DataModelPausibleOperationImpl.java:219)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.cacheThreadAndContinue(DataModelPausibleOperationImpl.java:89)
at org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.execute(DataModelPausibleOperationImpl.java:207)
at org.eclipse.wst.common.frameworks.internal.datamodel.ui.DataModelWizard$1CatchThrowableRunnableWithProgress.run(DataModelWizard.java:220)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
Caused by: org.eclipse.wst.common.frameworks.internal.enablement.nonui.WFTWrappedException: Error importing Module File
at org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.importModuleFile(J2EEArtifactImportOperation.java:127)
at org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.doExecute(J2EEArtifactImportOperation.java:87)
... 13 more
Caused by: java.lang.NullPointerException
at org.eclipse.jst.j2ee.internal.archive.ComponentArchiveSaveAdapter.<init>(ComponentArchiveSaveAdapter.java:73)
at org.eclipse.jst.j2ee.internal.archive.J2EEComponentArchiveSaveAdapter.<init>(J2EEComponentArchiveSaveAdapter.java:43)
at org.eclipse.jst.j2ee.internal.archive.WebComponentArchiveSaveAdapter.<init>(WebComponentArchiveSaveAdapter.java:35)
at org.eclipse.jst.j2ee.internal.web.archive.operations.WebComponentImportOperation.getArchiveSaveAdapter(WebComponentImportOperation.java:130)
at org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.importModuleFile(J2EEArtifactImportOperation.java:120)
... 14 more

Any help as to what is causing this. Not much help from other forums.

Regards,
Jiten
Re: Not able to import a war file in Eclipse 2020-06. [message #1849618 is a reply to message #1849595] Thu, 27 January 2022 01:49 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4264
Registered: July 2009
Senior Member

No recent and supported version of Eclipse or the Web Tools Platform runs on Java 1.8. Update, and either use the provided Java 17 or a Java 11 runtime.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Tue, 01 March 2022 13:19]

Report message to a moderator

Re: Not able to import a war file in Eclipse 2020-06. [message #1850399 is a reply to message #1849618] Tue, 01 March 2022 12:27 Go to previous message
Jiten Panna is currently offline Jiten PannaFriend
Messages: 2
Registered: January 2022
Junior Member
Thanks Nitin!
I was able to import it to Eclipse 2021-12R version.

Regards,
Jiten Panna
Previous Topic:Assistance required- Compatibility issue with Eclipse IDE and Maven
Next Topic:Marketplace via HTTP (not HTTPS)
Goto Forum:
  


Current Time: Sun Sep 25 08:28:25 GMT 2022

Powered by FUDForum. Page generated in 0.03453 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top