Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Old Eclipse Versions and the Log4J vulnerability(Are this Old Eclipse Versions affected by Log4J?)
Old Eclipse Versions and the Log4J vulnerability [message #1849056] Fri, 31 December 2021 08:51 Go to next message
Pascal Gdakowska is currently offline Pascal GdakowskaFriend
Messages: 1
Registered: December 2021
Junior Member
`Hello,

I am currently researching if the Eclipse Versions Neon, Oxygen, 2020.3 and the IDE itself are affected by the Log4J vulnerability.

I couldnt find any informations on the internet. The only thing I found is the following list, where all this versions are not listed. https://wiki.eclipse.org/Eclipse_and_log4j2_vulnerability_(CVE-2021-44228)


Thank you in advance and hope you have a nice 2022 :)

With best Regards

Pascal
Re: Old Eclipse Versions and the Log4J vulnerability [message #1849062 is a reply to message #1849056] Fri, 31 December 2021 15:26 Go to previous message
Thomas Wolf is currently offline Thomas WolfFriend
Messages: 424
Registered: August 2016
Senior Member
I think this cannot be answered in general; it may depend on which plug-ins are installed.

Check what plugin-ins are installed and active when Eclipse runs. Check whether logging via log4j2 occurs at all. Depending on what bundles are installed, logging may not occur anyway, or may use a different logging back-end.
Previous Topic:Darkest Dark Theme with DevStyle theme not available
Next Topic:workspace refresh
Goto Forum:
  


Current Time: Sun Jan 23 07:08:56 GMT 2022

Powered by FUDForum. Page generated in 0.02506 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top