Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Updating Eclipse do not work(Conflicting dependency by updating Eclipse)
Updating Eclipse do not work [message #1848125] Mon, 22 November 2021 08:26 Go to next message
René Stentzel is currently offline René StentzelFriend
Messages: 1
Registered: November 2021
Junior Member
Hi everyone.
I'm trying to update Eclipse by included update functionality but it doesn't work.
I currently have Eclipse version 2020-12 (4.18.0) installed. When Eclipse is checking for updates it discovered new versions for

  • Eclipse Platform
  • Eclipse RCP
  • WST Server Adapters
  • WST Server UI

Unfortunately, updating this components cannot perform:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Eclipse Platform 4.21.0.v20210906-0842 (org.eclipse.platform.feature.group 4.21.0.v20210906-0842)
  Software currently installed: Eclipse for Testers 4.18.0.20201210-1200 (epp.package.testing 4.18.0.20201210-1200)
  Only one of the following can be installed at once: 
    Ant Build Tool Core 3.5.800.v20200608-1251 (org.eclipse.ant.core 3.5.800.v20200608-1251)
    Ant Build Tool Core 3.6.100.v20210731-1643 (org.eclipse.ant.core 3.6.100.v20210731-1643)
  Cannot satisfy dependency:
    From: Eclipse for Testers 4.18.0.20201210-1200 (epp.package.testing 4.18.0.20201210-1200)
    To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.18.0.v20201202-1800,4.18.0.v20201202-1800]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.18.0.v20201202-1800 (org.eclipse.platform.feature.group 4.18.0.v20201202-1800)
    To: org.eclipse.equinox.p2.iu; org.eclipse.ant.core [3.5.800.v20200608-1251,3.5.800.v20200608-1251]
  Cannot satisfy dependency:
    From: Eclipse Platform 4.21.0.v20210906-0842 (org.eclipse.platform.feature.group 4.21.0.v20210906-0842)
    To: org.eclipse.equinox.p2.iu; org.eclipse.ant.core [3.6.100.v20210731-1643,3.6.100.v20210731-1643]

Is there any way to resolving this dependency conflicts without installing Eclipse from scratch?
Re: Updating Eclipse do not work [message #1848159 is a reply to message #1848125] Mon, 22 November 2021 21:19 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4165
Registered: July 2009
Senior Member

It seems not, based on the way Eclipse for Testers was defined and that you already have the final version of it (see https://www.eclipse.org/lists/cross-project-issues-dev/msg18159.html). You could
try to uninstall Eclipse for Testers from within Eclipse, but I have no idea if that'll lave you a runnable installation.


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Mon, 22 November 2021 21:23]

Report message to a moderator

Previous Topic:Failed to create Virtual Machine
Next Topic:Javadoc not working with module projects
Goto Forum:
  


Current Time: Sun Jan 23 18:11:05 GMT 2022

Powered by FUDForum. Page generated in 0.03260 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top