Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Eclipse Linux 21.09 gives errors not taking into account C++ dialect(Eclipse Linux 21.09 gives errors not taking into account C++ dialect)
Eclipse Linux 21.09 gives errors not taking into account C++ dialect [message #1848116] Sun, 21 November 2021 16:18 Go to next message
Bert Aerts is currently offline Bert AertsFriend
Messages: 1
Registered: November 2021
Junior Member
I have Eclipse 21.09 installed in Ubuntu 21.10.
I have a project that has a setting
C/C++ Build / Settings / GCC C++ Compiler / Dialect ISO C++ 20 in drop down list
But in the editor
#include <concepts> // only supported in C++ 20

template<std::copyable T>

I get the error Type 'std::copyable' could not be resolved.
But the project builds OK.
Is there a setting for code analysis that I should set?
Re: Eclipse Linux 21.09 gives errors not taking into account C++ dialect [message #1848123 is a reply to message #1848116] Mon, 22 November 2021 02:43 Go to previous messageGo to next message
David VavraFriend
Messages: 1430
Registered: October 2012
Senior Member
IIRC, there was a bug report on this and the resolution was
essentially the parser doesn't support C++20 and interest
in fixing it is lacking.

Perhaps you'd like to volunteer.
Re: Eclipse Linux 21.09 gives errors not taking into account C++ dialect [message #1848781 is a reply to message #1848123] Thu, 16 December 2021 14:59 Go to previous message
John Glen is currently offline John GlenFriend
Messages: 7
Registered: December 2021
Junior Member
In addition to this, setting the dialect flag to C++20 completely breaks static analysis for custom classes.
Previous Topic:Minimized console pane opens on right side on build.
Next Topic:No paths in 'Hello World' example
Goto Forum:
  


Current Time: Mon Sep 26 06:36:52 GMT 2022

Powered by FUDForum. Page generated in 0.02007 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top