Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Help for running Eclipse on a legacy Mac OS (10.9)
Help for running Eclipse on a legacy Mac OS (10.9) [message #1847381] Mon, 25 October 2021 18:07 Go to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
I have an old iMac running Mac OS 10.9. I was curious to see if I could get Eclipse to run on it. I've been trying various versions of Eclipse. The last version I was able to run was 3.6. I read that 4.4 should be able to run, but I get an error which is beyond my level of competence,

If this system is too old for anybody to bother, I understand.

[Updated on: Mon, 25 October 2021 18:09]

Report message to a moderator

Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847384 is a reply to message #1847381] Mon, 25 October 2021 18:46 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 730
Registered: August 2014
Senior Member
The Java on your computer may be 32 bits.

The current Eclipse versions need 64 bit Java to run.

The hardware running OS X 10.9 should be OK for 64 bits.


--

Tauno Voipio
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847399 is a reply to message #1847384] Tue, 26 October 2021 01:58 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
Because Apple doesn't support an OS higher than Lion (10.7) on my iMac, I installed a modified version of 10.9 (Mavericks) on my machine.

64 bit apps appear to run just fine. I don't understand why Eclipse 4.4 won't run, because it was certified at the time to run on 10.9.

When I get home I will attach the metadata.log file.
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847429 is a reply to message #1847384] Tue, 26 October 2021 22:00 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
Current versions of Eclipse require 10.10. Do you know the youngest version of Eclipse to run on 10.9?
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847440 is a reply to message #1847429] Wed, 27 October 2021 08:20 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 730
Registered: August 2014
Senior Member
Get Java JDK from Java pages. Remember to select 64 bit version, if there are choices. Version 8 (also called 1.8) should fit in well, and the information is a bit fuzzy, version 11 could.

The Java version limits what release of Eclipse you can run.

Please use the Eclipse installer to set Eclipse up.


--

Tauno Voipio
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847455 is a reply to message #1847440] Thu, 28 October 2021 01:08 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
The current version of the Eclipse installer requires 10.10 and earlier versions crash.
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847468 is a reply to message #1847455] Thu, 28 October 2021 09:53 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 730
Registered: August 2014
Senior Member
Have you attempted to install Java 11?

It might work. Sorry, I do not have an OS X older than El Capitan, anymore.


--

Tauno Voipio
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1847491 is a reply to message #1847468] Fri, 29 October 2021 00:38 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
Yes, I installed Java 11.
Re: Help for running Eclipse on a legacy Mac OS (10.9) [message #1854188 is a reply to message #1847491] Fri, 05 August 2022 08:00 Go to previous message
Robbyn MAysaa is currently offline Robbyn MAysaaFriend
Messages: 1
Registered: August 2022
Junior Member
Thanks for the suggestions! I have just got an old Mac and would like to set it up.
Previous Topic:UnsupportedConfigurationException: Project workspace location matches workspace root
Next Topic:***Install eclipse plugin via command line***
Goto Forum:
  


Current Time: Thu Sep 29 14:49:28 GMT 2022

Powered by FUDForum. Page generated in 0.04323 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top