Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot complete the install because some dependencies are not satisfiable
Cannot complete the install because some dependencies are not satisfiable [message #1847344] Sun, 24 October 2021 02:16 Go to next message
H CK is currently offline H CKFriend
Messages: 1
Registered: October 2021
Junior Member
Hello All,

When I was trying to install Checkstyle Plugin from:
https://marketplace.eclipse.org/marketplace-client-intro?mpc_install=150

It shows:
Cannot complete the provisioning operation. Please change your selection and try again. See below for details.

My current project is on java 11, I also had set the following in eclipse.ini, to make 1.8 my default:
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_281.jdk/Contents/Home/jre/bin

I tried to change my environment but I could't find the solution.
If someone knows how to deal with this problem please help!
Many thanks!

=====================

Detail messages below:

Cannot complete the install because some dependencies are not satisfiable
Software being installed: a.jre.javase 16.0.0
Software currently installed: Eclipse Java Web Developer Tools 3.18.0.v202005181429 (org.eclipse.jst.web_ui.feature.feature.group 3.18.0.v202005181429)
Cannot satisfy dependency:
From: Eclipse Java Web Developer Tools 3.18.0.v202005181429 (org.eclipse.jst.web_ui.feature.feature.group 3.18.0.v202005181429)
To: org.eclipse.equinox.p2.iu; org.eclipse.wst.ws_ui.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: Web Services Tools 3.9.100.v202004082157 (org.eclipse.wst.ws_ui.feature.feature.group 3.9.100.v202004082157)
To: org.eclipse.equinox.p2.iu; org.eclipse.wst.wsdl.ui 0.0.0
Cannot satisfy dependency:
From: WSDL UI 1.3.100.v202004082216 (org.eclipse.wst.wsdl.ui 1.3.100.v202004082216)
To: osgi.bundle; org.eclipse.wst.wsdl.validation [1.1.0,2.0.0)
Cannot satisfy dependency:
From: WSDL Validator 1.3.0.v202101270311 (org.eclipse.wst.wsdl.validation 1.3.0.v202101270311)
To: osgi.ee; (&(osgi.ee=JavaSE)(version=11))
Re: Cannot complete the install because some dependencies are not satisfiable [message #1847356 is a reply to message #1847344] Mon, 25 October 2021 06:10 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4165
Registered: July 2009
Senior Member

Which release of Eclipse is this? Those dependencies need you to run Eclipse with Java 11 because they require Java 11.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Will Eclipse 4.21 run on Mac OS 10.11.6?
Next Topic:Content Assist Broken
Goto Forum:
  


Current Time: Tue Jan 25 02:06:10 GMT 2022

Powered by FUDForum. Page generated in 0.03007 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top