Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Will Eclipse 4.21 run on Mac OS 10.11.6?
Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847225] Wed, 20 October 2021 03:09 Go to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
Eclipse 4.21 is crashing on startup on my iMac running Mac OS 10.11.6. Is Eclipse 4.21 compatible with Mac OS 10.11.6?
Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847226 is a reply to message #1847225] Wed, 20 October 2021 04:32 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4144
Registered: July 2009
Senior Member

Looks like no, as it's 5 releases and years old. 4.21 was tested with Big Sur and Catalina. https://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_21.xml#target_environments

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847233 is a reply to message #1847226] Wed, 20 October 2021 11:58 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 686
Registered: August 2014
Senior Member
I'm using OS X 10.11.6 El Capitan, on my old MacPro server.

After installing Java 11.0.7, Eclipse 2021-09 runs well on it.


--

Tauno Voipio
Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847244 is a reply to message #1847233] Wed, 20 October 2021 23:31 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
Tauno Voipio wrote on Wed, 20 October 2021 11:58
I'm using OS X 10.11.6 El Capitan, on my old MacPro server.

After installing Java 11.0.7, Eclipse 2021-09 runs well on it.


Doesn't the installer install Java automatically?
Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847245 is a reply to message #1847244] Thu, 21 October 2021 06:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32111
Registered: July 2009
Senior Member
Yes, that choice is available in the installer. You can also choose a version already installed on your machine, if that's available and of a high enough version.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847328 is a reply to message #1847245] Fri, 22 October 2021 16:08 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
Oct. 22, 2021.
I have resolved the issue.

Installing Eclipse with JRE version 17.0.0 will install Eclipse, but Eclipse will crash on startup. JRE version 11.0.12 works.

Summary:
Ran the installer again for a fourth time. I ran it two times choosing eclpse platform as my package and the third time the package for Java developers. Those all failed.

The fourth time I chose the Eclipse Platform package, but then at the second dialog window I left the Eclipse version as it was and chose JRE version 11.0.12, the minimum version offered.

So nice to see that Welcome screen.

I have not tried the other versions of the JRE except for version 17.0.0 which was causing Eclipse to crash. As of today the Eclipse installer offers JRE versions 17.0.0, 16.0.2, 15.0.2, 14.0.2, and 11.0.12.
Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847329 is a reply to message #1847225] Fri, 22 October 2021 16:16 Go to previous messageGo to next message
Ivan Frey is currently offline Ivan FreyFriend
Messages: 9
Registered: October 2021
Junior Member
No Message Body

[Updated on: Fri, 22 October 2021 16:17]

Report message to a moderator

Re: Will Eclipse 4.21 run on Mac OS 10.11.6? [message #1847333 is a reply to message #1847328] Fri, 22 October 2021 18:33 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 686
Registered: August 2014
Senior Member
Eclipse recommends using a LTS (Long Time Support) version of Java.

The currently ripe LTS versions are 8 and 11. 17 will be, but it is not considered ripe yet. For more information, Google for Java versions.


--

Tauno Voipio
Previous Topic:Invalid thread access
Next Topic:Cannot complete the install because some dependencies are not satisfiable
Goto Forum:
  


Current Time: Sun Dec 05 22:37:23 GMT 2021

Powered by FUDForum. Page generated in 0.04820 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top