Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » Setting up Eclipse for Developing with ATMEGA1284
Setting up Eclipse for Developing with ATMEGA1284 [message #1845085] Wed, 06 October 2021 08:54 Go to next message
ailee ll is currently offline ailee llFriend
Messages: 2
Registered: August 2016
Junior Member
I'm trying to set up Eclipse for AVR development on my Linux machine. The only problem is Eclipse can't find avr/io.h or util/delay.h. I've used Atmel Studio on my Windows machine and it automatically imports these files based on my specific microcontroller. How can I do the same with the Eclipse I have set up as shown in the link? If it makes a difference, I'm using a USB Tiny ISP and an ATMEGA1284.https://www.apogeeweb.net/circuitry/atmega1284-microcontroller-arduino-pinout-datasheet.html
Re: Setting up Eclipse for Developing with ATMEGA1284 [message #1845099 is a reply to message #1845085] Wed, 06 October 2021 17:17 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 733
Registered: August 2014
Senior Member
It seems that you are missing the AVR compiler and run-time library or you did not create a cross-compilation project using them.

You did not tell which distribution of Linux.

In Debian-style distributions, the compiler and utilities are in package gcc-avr, and the run-time library with headers (including the missing ones) are in package avr-libc.


--

Tauno Voipio
Previous Topic:2021-06 Update fails
Next Topic:C-Lang
Goto Forum:
  


Current Time: Fri Oct 07 04:02:49 GMT 2022

Powered by FUDForum. Page generated in 0.01946 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top