Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot install Spring Tools 3 Add-On for Spring Tools 4 from Marketplace(Trying to install Spring Tools 3 Add-On for Spring Tools 4 3.9.18 RELEASE from Marketplace gets me an error)
Cannot install Spring Tools 3 Add-On for Spring Tools 4 from Marketplace [message #1845019] Sun, 03 October 2021 08:59 Go to next message
Carlos Ernesto Velazquez Rodriguez is currently offline Carlos Ernesto Velazquez RodriguezFriend
Messages: 1
Registered: October 2021
Junior Member
Hi everyone

This is my version of STS:

Spring Tool Suite 4

Version: 4.12.0.RELEASE
Build Id: 202109130635


I do have connection with Marketplace. I can install others solutions from it, but when I try to install Spring Tools 3 Add-On for Spring Tools 4, I always get this error:

Cannot complete the install because one or more required items could not be found.
Software being installed: Spring IDE AOP Extension (optional) 3.9.18.202109140629-RELEASE (org.springframework.ide.eclipse.aop.feature.feature.group 3.9.18.202109140629-RELEASE)
Missing requirement: Spring IDE Core (required) 3.9.18.202109140629-RELEASE (org.springframework.ide.eclipse.feature.feature.group 3.9.18.202109140629-RELEASE) requires 'org.eclipse.equinox.p2.iu; org.eclipse.wst.xml_ui.feature.feature.group 0.0.0' but it could not be found
Cannot satisfy dependency:
From: Spring IDE AOP Extension (optional) 3.9.18.202109140629-RELEASE (org.springframework.ide.eclipse.aop.feature.feature.group 3.9.18.202109140629-RELEASE)
To: org.eclipse.equinox.p2.iu; org.springframework.ide.eclipse.feature.feature.group 0.0.0


Which may be the solution for this error? Am I doing something wrong or perhaps I have missed something?

I have uploaded an attachment with an screenshot of the error that I am getting.
Re: Cannot install Spring Tools 3 Add-On for Spring Tools 4 from Marketplace [message #1845031 is a reply to message #1845019] Mon, 04 October 2021 07:16 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32082
Registered: July 2009
Senior Member
Probably this feature is expecting you to be installing in the "Eclipse IDE for Enterprise Java and Web Developers" where this "missing" feature is already installed. In your Window -> Preferences -> Install/Update -> Available Software Sites is https://download.eclipse.org/releases/2021-09 in the list and checked (enabled)? In the worst case, use Help -> Install New Software..., choose/enter https://download.eclipse.org/releases/2021-09, look for "Eclipse XML Editors and Tools" and install that first.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Im new to minecraft coding and I tried to open the game with run and this error poped up
Next Topic:JFrame design tab WindowBuilder disappear when importing project
Goto Forum:
  


Current Time: Thu Oct 28 21:40:14 GMT 2021

Powered by FUDForum. Page generated in 0.02462 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top