Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Run Eclipse on Java 17 (latest LTS JDK)(Any possibility to run Eclipse on the latest LTS JDK?)
Run Eclipse on Java 17 (latest LTS JDK) [message #1844564] Thu, 16 September 2021 15:10 Go to next message
Alexandr Bolbat is currently offline Alexandr BolbatFriend
Messages: 7
Registered: September 2021
Junior Member
Hello

Any possibility to run Eclipse on the latest LTS JDK?
Currently i see this exception:
index.php/fa/40992/0/

OS: macOS Big Sur
Java:
- java version "17" 2021-09-14 LTS
- Java(TM) SE Runtime Environment (build 17+35-LTS-2724)
- Java HotSpot(TM) 64-Bit Server VM (build 17+35-LTS-2724, mixed mode, sharing)


With Java 11 all works fine.
Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844581 is a reply to message #1844564] Fri, 17 September 2021 03:51 Go to previous messageGo to next message
Jay Arthanareeswaran is currently offline Jay ArthanareeswaranFriend
Messages: 71
Registered: July 2009
Member
Can you share what you have for -vm in the eclipse.ini file? I have the following and it works fine.

-vm
/Users/jay/Java/jdk-17/Contents/Home/bin/java
Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844583 is a reply to message #1844581] Fri, 17 September 2021 05:14 Go to previous messageGo to next message
Sravan Kumar Lakkimsetti is currently offline Sravan Kumar LakkimsettiFriend
Messages: 14
Registered: February 2014
Junior Member
I don't see this problem on the following configuration

OS: macos 11.6
Java: Java 17 hotspot
arch: x86_64
Eclipse committers package.

Can you please check whether you get java 17 as default with
/usr/libexec/java_home
and architecture matches with java and eclipse.
you can get architecture of JVM using
/usr/libexec/java_home -V
Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844586 is a reply to message #1844564] Fri, 17 September 2021 07:17 Go to previous messageGo to next message
Alexandr Bolbat is currently offline Alexandr BolbatFriend
Messages: 7
Registered: September 2021
Junior Member
I have changed only:

Info.plist - configured right JDK (11 or 17)
index.php/fa/40994/0/

eclipse.ini - only increased memory parameters
index.php/fa/40995/0/

Java configuration:
index.php/fa/40996/0/
index.php/fa/40997/0/
index.php/fa/40998/0/

[Updated on: Fri, 17 September 2021 07:19]

Report message to a moderator

Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844587 is a reply to message #1844586] Fri, 17 September 2021 07:26 Go to previous messageGo to next message
Alexandr Bolbat is currently offline Alexandr BolbatFriend
Messages: 7
Registered: September 2021
Junior Member
Maybe this is because JDK 17 architecture is arm64?
Currently i have latest macbook on m1 processor and installed it

But eclipse build is for x86_64 architecture

[Updated on: Fri, 17 September 2021 07:40]

Report message to a moderator

Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844588 is a reply to message #1844587] Fri, 17 September 2021 07:39 Go to previous messageGo to next message
Alexandr Bolbat is currently offline Alexandr BolbatFriend
Messages: 7
Registered: September 2021
Junior Member
JDK 17 (arm64) works much faster on m1 cpu, as example i've got 65% reduced build time for one of our big projects which is ready to migrate to Java 17
Java 17 support installed in eclipse from Marketplace works fine with projects configured to use JDK 17 (arm64)

I think for now for me Eclipse still will be started with JDK 11 (x86_64) and I will migrate it to JDK 17 (arm64) when Eclipse release bundle for macOS (arm64) will be ready

[Updated on: Fri, 17 September 2021 07:41]

Report message to a moderator

Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844589 is a reply to message #1844588] Fri, 17 September 2021 07:44 Go to previous messageGo to next message
Alexandr Bolbat is currently offline Alexandr BolbatFriend
Messages: 7
Registered: September 2021
Junior Member
From ticket i understand that Eclipse bundle for macOS (arm64) still not released

[Updated on: Fri, 17 September 2021 07:44]

Report message to a moderator

Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844596 is a reply to message #1844589] Fri, 17 September 2021 08:47 Go to previous messageGo to next message
Lakshmi P ShanmugamFriend
Messages: 278
Registered: July 2009
Location: India
Senior Member
Hi Alexandr,

The architecture types of Eclipse and the JVM should match. So, the combinations that will work on Mac M1 are:

Eclipse (x86_64) with Java (x86_64)
Eclipse (arm64) with Java (arm64)

These combinations will not work:

Eclipse (x86_64) with Java (arm64)
Eclipse (arm64) with Java (x86_64)

The Eclipse installer and IDE packages for Mac arm64 are not yet available, but the Eclipse SDK build for arm64 is available here [1]. You need the Mac OSX (64 bit version for Arm64/AArch64) download from the page and should be able to run this with Java 17 (arm64).

Please note that it's the base Eclipse SDK and you will have to install the additional plugins that are required.

[1] - https://download.eclipse.org/eclipse/downloads/drops4/R-4.21-202109060500/

HTH


Lakshmi P Shanmugam

[Updated on: Fri, 17 September 2021 08:49]

Report message to a moderator

Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844598 is a reply to message #1844596] Fri, 17 September 2021 08:53 Go to previous messageGo to next message
Alexandr Bolbat is currently offline Alexandr BolbatFriend
Messages: 7
Registered: September 2021
Junior Member
Thx Lakshmi

I will wait when related release bundle will be available, hope this will be in near future :)
Re: Run Eclipse on Java 17 (latest LTS JDK) [message #1844621 is a reply to message #1844564] Fri, 17 September 2021 18:37 Go to previous message
Holger Isenberg is currently offline Holger IsenbergFriend
Messages: 1
Registered: September 2021
Junior Member
Which specific plugins or components are you missing when using the installer DMG package eclipse-SDK-4.21-macosx-cocoa-aarch64.dmg from Lakshmi's URL above?

After installing the DMG you can add components in Menu Help -> Install New Software -> Add...

Components from other sources you can include there by pointing to a new installation site, for Eclipse MAT for example:
https://download.eclipse.org/mat/latest/update-site/

Previous Topic:Trouble opening eclipse on Macbook
Next Topic:Cannot invoke "org.eclipse.jdt.launching.IVMInstall.getLibraryLocations()"
Goto Forum:
  


Current Time: Sun Oct 24 10:51:07 GMT 2021

Powered by FUDForum. Page generated in 0.01967 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top