Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot complete the install because one or more required items could not be found.(Software being installed: POM Editor using LemMinX language server (includes Incubating components) 1.18.1.20210621-0748 (org.eclipse.m2e.lemminx.feature.feature.group 1.18.1.20210621-0748) FAILED)
Cannot complete the install because one or more required items could not be found. [message #1844440] Tue, 14 September 2021 07:01 Go to next message
Mamatweli Turdy is currently offline Mamatweli TurdyFriend
Messages: 1
Registered: September 2021
Junior Member
Hello:

>>> I am using Eclipse on Ununtu 21.04.

>>> I am using following version/build
Eclipse IDE for Enterprise Java and Web Developers (includes Incubating components)

Version: 2021-06 (4.20.0)
Build id: 20210612-2011

>>>

When I tried to update Eclipse, I encountered the below message, I cannot seem to find the solution even on Google (unless I am not searching for the right key works -- mainly because I could not figure out what to search for , apart from I tried to split the error message and separately searched for it )

Cannot complete the install because one or more required items could not be found.
Software being installed: POM Editor using LemMinX language server (includes Incubating components) 1.18.1.20210621-0748 (org.eclipse.m2e.lemminx.feature.feature.group 1.18.1.20210621-0748)
Missing requirement: POM Editor using LemMinX language server (includes Incubating components) 1.18.1.20210621-0748 (org.eclipse.m2e.lemminx.feature.feature.group 1.18.1.20210621-0748) requires 'org.eclipse.equinox.p2.iu; org.eclipse.m2e.editor.lemminx [1.18.1.20210621-0748,1.18.1.20210621-0748]' but it could not be found

PS: (About attached photo)

1) by default the update is selected, but 2) the 'Next' options is not available
I need to click 'Select All' to make it available
2) even after it becomes available, when I click on 'Next' nothing happens

I don't know how much are this two issues related to each other, wanted to provide additional info.


>>>>> HAS ANYONE EVER ENCOUNTERED THIS ISSUE AS WELL?

Can you please share how you resolved or if you happen to know the solution, how should I resolve this issue?

Thanks a million in advance!
  • Attachment: Untitled.png
    (Size: 69.67KB, Downloaded 24 times)
Re: Cannot complete the install because one or more required items could not be found. [message #1844467 is a reply to message #1844440] Tue, 14 September 2021 14:19 Go to previous message
Anne Ranch is currently offline Anne RanchFriend
Messages: 57
Registered: October 2020
Member
Are you using current Eclipse installer ?
https://www.eclipse.org/downloads/packages/installer
I had some issues getting Ubuntu 21.04 "run" the installer.
I ended up downloading for Windows...

In past weird issues like your was using the "official mirror" and selection "all sites" for update....
Previous Topic:Eclipse installation steps in Citrix for shared users (70+)
Next Topic:Pydev debugger giving AttributeError
Goto Forum:
  


Current Time: Fri Jan 28 22:33:55 GMT 2022

Powered by FUDForum. Page generated in 0.04376 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top