Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » Blobless clones fail in Eclipse/Egit(Blobless clones)
Blobless clones fail in Eclipse/Egit [message #1844189] Mon, 06 September 2021 03:00
Amanda Jackson is currently offline Amanda JacksonFriend
Messages: 1
Registered: September 2021
Junior Member
I've encountered a hiccup when using blobless clones.

I successfully created a blobless clone using Git Bash, then jumped into Eclipse to create a branch so I could start porting, but kept getting errors. Even though it displayed an error, it did create the branch but didn't check it out. If trying to check it out in Eclipse, same error occurs. Jumped back into Git Bash and was able to check out the branch okay, so thinking this is an Eclipse issue. Possibly something to do with a long filename and eGit didn't handle it as well as Git Bash, which noted the error but allowed the checkout to continue.

We've not had any issues using Git Bash or Git Extensions.

I have things on my to do list to try out around blobless clones (when I get spare time) including retrying this process on a different branch that doesn't have any potential long filename issues to see if that was the entire cause of the problem.

Tried raising a bug but got stuck in a loop of asking me to create an account even though I already have an account.
Previous Topic:Problem regarding Existing project was support by Mylyn
Next Topic:JGit DFS repository with HEAD pointing to main instead of master
Goto Forum:
  


Current Time: Wed Sep 28 10:04:51 GMT 2022

Powered by FUDForum. Page generated in 0.02126 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top