Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Issue to start application
Issue to start application [message #1843978] Thu, 26 August 2021 02:57 Go to next message
HuaMin Chen is currently offline HuaMin ChenFriend
Messages: 21
Registered: February 2015
Junior Member
Hi,
How to start "org.eclipse.equinox.launcher_1.6.200.v20210416-2027.jar" within Ubuntu 20.04?

-startup
plugins/org.eclipse.equinox.launcher_1.6.200.v20210416-2027.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.2.200.v20210429-1609
-product
org.eclipse.epp.package.java.product
-showsplash
org.eclipse.epp.package.common

Re: Issue to start application [message #1843981 is a reply to message #1843978] Thu, 26 August 2021 04:30 Go to previous messageGo to next message
Jay Arthanareeswaran is currently offline Jay ArthanareeswaranFriend
Messages: 70
Registered: July 2009
Member
This is JDT forum and I don't see many responding to a question on Equinox. Do you want to post it on Equinox forum?
https://www.eclipse.org/forums/index.php/f/31/
Re: Issue to start application [message #1843984 is a reply to message #1843981] Thu, 26 August 2021 05:58 Go to previous messageGo to next message
HuaMin Chen is currently offline HuaMin ChenFriend
Messages: 21
Registered: February 2015
Junior Member
Hi,
Should I re-post the same to that? Or can this thread be moved to that?

[Updated on: Thu, 26 August 2021 06:20]

Report message to a moderator

Re: Issue to start application [message #1843989 is a reply to message #1843984] Thu, 26 August 2021 08:34 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32069
Registered: July 2009
Senior Member
I'm not sure how to "move" threads, so re-post.

However, if you can launch the application from within the IDE (should be easy via a launch configuration then in the Debug view in the Debug perspective, you can use the context menu of the launch application (even after terminated) and look at the Properties which will show you the complete command line used to launch that thing which should answer your question more quickly than re-posting.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Issue to start application [message #1844006 is a reply to message #1843989] Fri, 27 August 2021 02:30 Go to previous messageGo to next message
HuaMin Chen is currently offline HuaMin ChenFriend
Messages: 21
Registered: February 2015
Junior Member
Can you help to issue below?

root@may-VirtualBox:/home/may/Desktop/Eclipse Java/plugins# java org.eclipse.equinox.launcher_1.6.200.v20210416-2027
Error: Could not find or load main class org.eclipse.equinox.launcher_1.6.200.v20210416-2027
Caused by: java.lang.ClassNotFoundException: org.eclipse.equinox.launcher_1.6.200.v20210416-2027

[Updated on: Fri, 27 August 2021 03:05]

Report message to a moderator

Re: Issue to start application [message #1844007 is a reply to message #1844006] Fri, 27 August 2021 04:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32069
Registered: July 2009
Senior Member
I can only guess what you've tried, so no, it not possible to help based on that. This is what a product launched from the IDE looks like for me on Windows:
"C:\Program Files\Java\jdk-11.0.9\bin\javaw.exe" -Xms1024m -Xmx2500m -XX:MaxPermSize=512m -Declipse.p2.max.threads=12 -Doomph.update.url=file:/D:/Users/merks/oomph-1.22/git/org.eclipse.oomph/sites/org.eclipse.oomph.site/target/repository/ -Doomph.redirection.setups=http://git.eclipse.org/c/oomph/org.eclipse.oomph.git/plain/setups/->file:/D:/Users/merks/oomph-1.22/git/org.eclipse.oomph/setups/ -Doomph.setup.remote.debug=maybe -Dorg.eclipse.emf.ecore.plugin.EcorePlugin.doNotLoadResourcesPlugin=true -Doomph.setup.stats.skip=true -Dorg.eclipse.swtbot.generator.enable=false -Duser.home=D:\Users\merks -Doomph.setup.user.home.redirect=true --add-modules=ALL-SYSTEM -Dfile.encoding=UTF-8 -classpath D:\Users\merks\.p2\pool\plugins\org.eclipse.equinox.launcher_1.6.300.v20210813-1054.jar org.eclipse.equinox.launcher.Main -launcher D:\Users\merks\oomph-1.22\ws\.metadata\.plugins\org.eclipse.pde.core\.install_folders\1627711905067\eclipse.exe -name Eclipse -showsplash 600 -product org.eclipse.oomph.setup.installer.product -data @noDefault -configuration "file:D:/Users/merks/oomph-1.22/ws/.metadata/.plugins/org.eclipse.pde.core/Setup (Installer Dialog)/" -dev "file:D:/Users/merks/oomph-1.22/ws/.metadata/.plugins/org.eclipse.pde.core/Setup (Installer Dialog)/dev.properties" -os win32 -ws win32 -arch x86_64 -nl en_US -consoleLog
Are you able to launch the IDE itself and try what I suggested?


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Issue to start application [message #1844009 is a reply to message #1844007] Fri, 27 August 2021 06:34 Go to previous messageGo to next message
HuaMin Chen is currently offline HuaMin ChenFriend
Messages: 21
Registered: February 2015
Junior Member
Can I have more details to launch it? My current issue is in Ubuntu OS.

[Updated on: Fri, 27 August 2021 07:00]

Report message to a moderator

Re: Issue to start application [message #1844010 is a reply to message #1844009] Fri, 27 August 2021 07:57 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32069
Registered: July 2009
Senior Member
You see the part of my response where I ask a question? If you don't answer such question that I ask and you don't provide more details about what you are actually trying that's failing, you should not expect to get a different answer than you got before.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Issue to start application [message #1844011 is a reply to message #1844010] Fri, 27 August 2021 08:05 Go to previous messageGo to next message
HuaMin Chen is currently offline HuaMin ChenFriend
Messages: 21
Registered: February 2015
Junior Member
> if you can launch the application from within the IDE (should be easy via a launch configuration then in the Debug view in the Debug perspective, you can use the context menu of the launch application

Really sorry to that I am not sure how to launch the current Eclipse application, now within Ubuntu.
Re: Issue to start application [message #1844027 is a reply to message #1844011] Sat, 28 August 2021 05:56 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32069
Registered: July 2009
Senior Member
Well, normally you just run the eclipse executable in the eclipse folder of the package/zip that you've downloaded and it does all the work of reading the eclipse.ini in order to launch the Java application.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Run Configuration Dependencies
Next Topic:Typing Lag Mac OS 10.14
Goto Forum:
  


Current Time: Tue Oct 19 07:04:20 GMT 2021

Powered by FUDForum. Page generated in 1.02257 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top