Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Proposals » Eclipse Sumo » FatalTraCIError Using traci.lane.getLastStepMeanSpeed(FatalTraCIError: connection closed by SUMO when using traci.lane.getLastStepMeanSpeed)
FatalTraCIError Using traci.lane.getLastStepMeanSpeed [message #1843975] Wed, 25 August 2021 22:25
Roland Oswald is currently offline Roland OswaldFriend
Messages: 1
Registered: August 2021
Junior Member
Hello,
I am very new to SUMO. I started working with it in maybe May of this year. But I didn't really start heavily using it until about one month ago.
I searched online for a similar issue and could not find anything so if someone knows of a similar issue that has been solved, I apologize for this post and please share it with me.

The problem I'm having is when I run my code, if the gui is zoomed out, the code runs fine, but as soon as I zoom in, or if I run the code started off zoomed in, the code crashes and I get this error:

Traceback (most recent call last):
  File "C:/Users/rdosw/Documents/SUMO/traci_tls/I-TSC.py", line 564, in <module>
    run()
  File "C:/Users/rdosw/Documents/SUMO/traci_tls/I-TSC.py", line 452, in run
    v_t[0][1] = traci.lane.getLastStepMeanSpeed(phases[0][1][0])
  File "C:\Program Files (x86)\Eclipse\Sumo\tools\traci\_lane.py", line 205, in getLastStepMeanSpeed
    return self._getUniversal(tc.LAST_STEP_MEAN_SPEED, laneID)
  File "C:\Program Files (x86)\Eclipse\Sumo\tools\traci\domain.py", line 172, in _getUniversal
    return _parse(self._retValFunc, varID, self._getCmd(varID, objectID, format, *values))
  File "C:\Program Files (x86)\Eclipse\Sumo\tools\traci\domain.py", line 177, in _getCmd
    r = self._connection._sendCmd(self._cmdGetID, varID, objID, format, *values)
  File "C:\Program Files (x86)\Eclipse\Sumo\tools\traci\connection.py", line 181, in _sendCmd
    return self._sendExact()
  File "C:\Program Files (x86)\Eclipse\Sumo\tools\traci\connection.py", line 91, in _sendExact
    raise FatalTraCIError("connection closed by SUMO")
traci.exceptions.FatalTraCIError: connection closed by SUMO



Like it stated earlier, this only happens when the gui is zoomed in so that I can see the vehicles running.
Does anyone know what could be causing this?
And, in the error is in the "traci_tls" folder, but I just copied that code and then added to it. I did not change the original "traci_tls" code.

Thank you
Previous Topic:DSL development
Next Topic:Vehicle 'xx' is not allowed to depart on edge 'xxxxxxxxxxxxxxxx'
Goto Forum:
  


Current Time: Sun Mar 03 13:43:28 GMT 2024

Powered by FUDForum. Page generated in 0.02179 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top