Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Unable to create the selected preference page.(New Install IDE 2021-06; New Workspace; Cannot view Installed JREs Preference Page)
Unable to create the selected preference page. [message #1843641] Wed, 11 August 2021 18:35 Go to next message
Chuck Minarik is currently offline Chuck MinarikFriend
Messages: 2
Registered: August 2021
Junior Member
My company has installed AdoptOpenJDK on my Windows 10 laptop...I believe this is the source of the problem.

I installed a fresh version of Eclipse IDE 2101-06 and started it with an empty workspace.

When I try to view Installed JREs in the Preferences section, I get an error that says: "Unable to create the selected preference page. An error occurred while automatically activating bundle org.eclipse.jdt.debug.ui (215)"

Is it possible to get Eclipse to work with AdoptOpenJDK?

I have attached a file with the error details.

TIA.

Re: Unable to create the selected preference page. [message #1843649 is a reply to message #1843641] Thu, 12 August 2021 04:50 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32819
Registered: July 2009
Senior Member
That sounds like this:

https://stackoverflow.com/questions/66011279/java-lang-classnotfoundexception-in-eclipse-using-jdi-debug-model-version3-17-0

You might try a newer (the latest) version: jdk-11.0.12+7_openj9-0.27.0


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Unable to create the selected preference page. [message #1843657 is a reply to message #1843649] Thu, 12 August 2021 12:22 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 259
Registered: April 2012
Senior Member
You need a full JDK to do Java development, not just a JRE, see Bug 569826, which is marked duplicate of Bug 567101.
Re: Unable to create the selected preference page. [message #1843658 is a reply to message #1843657] Thu, 12 August 2021 12:59 Go to previous message
Chuck Minarik is currently offline Chuck MinarikFriend
Messages: 2
Registered: August 2021
Junior Member
I reinstalled AdoptOpenJDK - with OpenJDK 11 and OpenJ9...it works now.

Thanks,, guys.
Previous Topic:Plugin Product Takes 10 minutes to start
Next Topic:CellEditor activation on double click
Goto Forum:
  


Current Time: Tue May 30 04:51:34 GMT 2023

Powered by FUDForum. Page generated in 0.01999 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top