Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » C / C++ IDE (CDT) » "Index -> Rebuild" gets ignored unless I delete the [Subprojects] folder from project t
"Index -> Rebuild" gets ignored unless I delete the [Subprojects] folder from project t [message #1843172] Sun, 18 July 2021 23:41
Hans Zimmer is currently offline Hans ZimmerFriend
Messages: 1
Registered: July 2021
Junior Member
I'm a Mechanical Engineering student, so not that much of a programmer. I'm trying to get into the deal.II finite element libary. When creating the Eclipse project with cmake as instructed in https://github.com/dealii/dealii/wiki/Eclipse, rebuilding the index (right click on project -> Index -> Rebuild) will not work unless I delete the [Subprojects] folder from the project tree. Found this out by accident but as far as I can tell it is completely reproduceable (will not happen with any other folders).

Any idea what could be the reason for this? I mean, I CAN get it to work just by deleting that folder, but I'd like to understand why that's happening and if there's anything I can do.

Screenshot is attached, in case there's any useful information in there.

Edit: Added a comparison of the project tree before and after deleting [Subprojects]. Interestingly, a folder "build" appears out of nowhere. It contains nothing but an empty folder named "default".

[Updated on: Mon, 19 July 2021 02:10]

Report message to a moderator

Previous Topic:How to display a custom tooltip on mouse hover over a line of code in C/C++ perspective?
Next Topic:run codan (Static Code Analysis) for C/C++ from cmd
Goto Forum:
  


Current Time: Sun Nov 28 03:28:50 GMT 2021

Powered by FUDForum. Page generated in 0.02096 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top