Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Jetty 9.4.42 installed in eclipse 2021-06 - Missing Constraints Validation error(Jetty 9.4.42 in eclipse 4.20 (2021-06) Validation Errors)
Jetty 9.4.42 installed in eclipse 2021-06 - Missing Constraints Validation error [message #1842558] Wed, 23 June 2021 16:13 Go to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 58
Registered: October 2012
Member
Hello,

I installed Jetty 9.4.42 in Eclipse 4.20 (2021-06) and got lots of validation errors. I verified that the missing plugins are installed but still reported as missing. Please see attached screenshot.

Example:
org.eclipse.jetty.alpn.client
Missing Constraint: Import-Package: org.eclipse.jetty.io; version= "[9.4.42,10.0.0)"
Missing Constraint: Import-Package: org.eclipse.jetty.util.log; version= "[9.4.42,10.0.0)"

Any input please.

Thanks,
Lea
Re: Jetty 9.4.42 installed in eclipse 2021-06 - Missing Constraints Validation error [message #1842559 is a reply to message #1842558] Wed, 23 June 2021 17:29 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4086
Registered: July 2009
Senior Member

What do you mean you "installed Jetty 9.4.42 in Eclipse 4.20"? Eclipse 4.20 contains bundles from Jetty 10.0.5.

Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 23 June 2021 17:30]

Report message to a moderator

Re: Jetty 9.4.42 installed in eclipse 2021-06 - Missing Constraints Validation error [message #1842561 is a reply to message #1842559] Wed, 23 June 2021 17:45 Go to previous messageGo to next message
lea ilagan is currently offline lea ilaganFriend
Messages: 58
Registered: October 2012
Member
Hello,

Yes, I installed Jetty 9.4.42 in eclipse 4.20.
We're currently using version 9.4.10 (https://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.4.10.v20180503/) and now upgrading it to latest 9.4.x using eclipse 4.20.
When i use Jetty 9.4.10 in eclipse 4.20, there is no validation error (not sure why). Can't we use latest 9.4.x in eclipse 4.20?

Also, yes, I see that eclipse 4.20 is using bundles from Jetty 10.x , however I can't find p2 repository to install 10.x.

Thanks,
Lea
Re: Jetty 9.4.42 installed in eclipse 2021-06 - Missing Constraints Validation error [message #1842564 is a reply to message #1842561] Wed, 23 June 2021 23:31 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4086
Registered: July 2009
Senior Member

You might find what you need by browsing https://download.eclipse.org/eclipse/jetty/ or https://download.eclipse.org/webtools/jetty/.
Check https://www.eclipse.org/lists/cross-project-issues-dev/msg18518.html for some information to watch for p2 repositories
directly from Jetty.


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Jetty 9.4.42 installed in eclipse 2021-06 - Missing Constraints Validation error [message #1842698 is a reply to message #1842564] Tue, 29 June 2021 10:07 Go to previous message
lea ilagan is currently offline lea ilaganFriend
Messages: 58
Registered: October 2012
Member

Thanks Nitin Dahyabhai..
I just pulled the 10.0.5 jetty bundles from maven site and create local p2 repo..

regards,
Leahttps://www.eclipse.org/forums/index.php/r/frm_id/89/
Previous Topic:Eclipse installation steps in Citrix for shared users (70+)
Next Topic:Want to run sample Hello world test on selenium grid 4
Goto Forum:
  


Current Time: Sun Jul 25 04:03:55 GMT 2021

Powered by FUDForum. Page generated in 0.08427 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top