Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Installing Sirius 6.5.1 on Eclipse 2021-06 Modeling fails
Installing Sirius 6.5.1 on Eclipse 2021-06 Modeling fails [message #1842372] Thu, 17 June 2021 10:13 Go to next message
Francesco Bedini is currently offline Francesco BediniFriend
Messages: 26
Registered: March 2018
Junior Member
Hi, I tried installing Sirius 6.5.1 on the newest eclipse and I can't succeed.
Using the update site i get:
index.php/fa/40641/0/

Using the marketplace I get the question:
"The following solutions are not available: Sirius 6.5
Proceed with the installation anyways?"
(Details: id=org.eclipse.sirius.sample.feature.group, site=https://download.eclipse.org/sirius/updates/releases/6.5.1/2020-09)

Proceeding, I get the new Sirius installed (the .aird files are migrated to the newest versions, but I can't then run an Eclipse Application (it would not even start and fail with an error).
  • Attachment: Sirius.png
    (Size: 54.66KB, Downloaded 404 times)
Re: Installing Sirius 6.5.1 on Eclipse 2021-06 Modeling fails [message #1842384 is a reply to message #1842372] Thu, 17 June 2021 12:47 Go to previous messageGo to next message
Florian Barbin is currently offline Florian BarbinFriend
Messages: 270
Registered: August 2010
Senior Member
Hi,

indeed you have to uncheck the 3 servers features (marked as experimental) to install the 6.5.1 version.
About the issue after the restart, can you try to delete the .lock file in <workspace directory>/.metadata and start eclipse again ?

Best regards,

Florian
Re: Installing Sirius 6.5.1 on Eclipse 2021-06 Modeling fails [message #1842387 is a reply to message #1842384] Thu, 17 June 2021 13:04 Go to previous messageGo to next message
Florian Barbin is currently offline Florian BarbinFriend
Messages: 270
Registered: August 2010
Senior Member
Here is the Sirius bugzilla about removing the deprecated Server experimental features: https://bugs.eclipse.org/bugs/show_bug.cgi?id=574125
Re: Installing Sirius 6.5.1 on Eclipse 2021-06 Modeling fails [message #1842389 is a reply to message #1842384] Thu, 17 June 2021 13:10 Go to previous messageGo to next message
Francesco Bedini is currently offline Francesco BediniFriend
Messages: 26
Registered: March 2018
Junior Member
I thought that I did unselect all experimental elements.
I tried again unselecting just the 3 server items and the installation did work.
When I restarted Eclipse, it failed to open. I then deleted the .lock file and at least it started.

Now when I try to start the second eclipse, I get those additional problems about dependencies:
index.php/fa/40647/0/
And then it fails to launch, see the .log if you want :)
  • Attachment: StartupProblem.png
    (Size: 10.51KB, Downloaded 336 times)
  • Attachment: .log
    (Size: 46.64KB, Downloaded 27 times)

[Updated on: Thu, 17 June 2021 13:11]

Report message to a moderator

Re: Installing Sirius 6.5.1 on Eclipse 2021-06 Modeling fails [message #1842393 is a reply to message #1842389] Thu, 17 June 2021 15:16 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7517
Registered: July 2009
Senior Member
Hi

Jetty caused considerable difficulties mandating a respin of 2021-06 RC2a to ensure that 'everyone' was using the same version. It is possible that this need for consistency did not spread to Sirius or one of its dependencies,. Unless you need to be right up to date you might consider continuing to use 2021-03.

Regards

Ed Willink
Previous Topic:Specifying sub-graphs using containers
Next Topic:Referencing other models and problems with services
Goto Forum:
  


Current Time: Wed Sep 28 17:18:11 GMT 2022

Powered by FUDForum. Page generated in 0.02384 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top