Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » SSLHandshakeException when using P2 Directory in Oomph (installing manually works)
SSLHandshakeException when using P2 Directory in Oomph (installing manually works) [message #1841579] Fri, 21 May 2021 07:32 Go to next message
Barrie Treloar is currently offline Barrie TreloarFriend
Messages: 54
Registered: July 2009
Member
I've followed https://wiki.eclipse.org/Eclipse_Oomph_Authoring#How_to_install_Eclipse_plugins_using_the_P2_Director_and_Repository_Explorer

* Created P2 Director node
* Added repository child task
* Added requirement child via drag and drop

Everything looks okay.

When I run the setup I get SSL Handshake errors.

I've added -Djavax.net.debug=all to the eclipse-inst.ini and ran on the command line to capture the errors.

After the ClientHello there isn't anything to indicate why it fails, just the error:

javax.net.ssl|DEBUG|24|Worker-3: https://raw.githubusercontent.com/iloveeclipse/plugins/latest/content.xml|2021-05-21 14:33:10.448 ACST|null:-1|Received alert message (
"Alert": {
  "level"      : "fatal",
  "description": "handshake_failure"
}
)
javax.net.ssl|ERROR|24|Worker-3: https://raw.githubusercontent.com/iloveeclipse/plugins/latest/content.xml|2021-05-21 14:33:10.448 ACST|null:-1|Fatal (HANDSHAKE_FAILURE): Received fatal alert: handshake_failure (
"throwable" : {
  javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure
        at java.base/sun.security.ssl.Alert.createSSLException(Unknown Source)


I can manually install AnyEdit via Help -> Install New Software ... -> Add -> "https://raw.githubusercontent.com/iloveeclipse/plugins/latest/". The only error you get is the lack of signed jar files.

I'm behind a firewall but the installers have been able to download all the other p2 dependencies previously so network settings should be fine.

I would normally expect certificate chain truncation or missing root certs in the keystore, but the error messages dont look like this and the CA is digicert which is bundled with Java.

Anyone got other thoughts to try?
Re: SSLHandshakeException when using P2 Directory in Oomph (installing manually works) [message #1841584 is a reply to message #1841579] Fri, 21 May 2021 08:55 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32109
Registered: July 2009
Senior Member
This seems strange. I wouldn't expect different behavior from Oomph versus what you do manually. Note though that the installer itself comes with an embedded JRE, at least the ones from the download page. You can get other ones from here:

https://wiki.eclipse.org/Eclipse_Installer

Have you tried using just http instead of https? That should avoid the problem (assuming no composite that is using an absolute URI with https in it is involved).


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:HELP
Next Topic:Proxy configuration is ignored (ERROR HTTP Proxy Authentication Required)
Goto Forum:
  


Current Time: Mon Nov 29 02:35:41 GMT 2021

Powered by FUDForum. Page generated in 0.01819 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top