Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » P2 Director Problem(How to resolve conflict)
P2 Director Problem [message #1840331] Mon, 12 April 2021 17:53 Go to next message
B Whitehead is currently offline B WhiteheadFriend
Messages: 4
Registered: April 2021
Junior Member
Shortly after each time I start Eclipse 3-21 the eclipse updater opens to say "P2 Director (Eclipse IDE for JavaScript and Web Developers (2020-06))" needs to be manually installed. When I to do that there is a whole stream of red error messages about conflicts (I can add those if it will help?)

About the same time this started, I can no longer open .css files without Eclipse hanging.

Are these two problems related and if so what is the solution?

Thanks in anticipation.

Brian
Re: P2 Director Problem [message #1840332 is a reply to message #1840331] Mon, 12 April 2021 17:57 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 4086
Registered: July 2009
Senior Member

The error messages couldn't hurt, but then you should already have the P2 Director installed in a normal situation. What is "Eclipse 3-21" and where did it come from?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: P2 Director Problem [message #1840337 is a reply to message #1840332] Mon, 12 April 2021 19:00 Go to previous messageGo to next message
B Whitehead is currently offline B WhiteheadFriend
Messages: 4
Registered: April 2021
Junior Member
Thanks for the swift response.

The Eclipse is 2021-03, not what I said before, sorry. It originally came from the Eclipse site but has been updated many times since. It is running on Linux Mint.

Please see attachment for first error massage.

Following is a copy & paste of the results:

Executing startup tasks
OpenJDK Runtime Environment 11.0.10+9-Ubuntu-0ubuntu1.20.04
Product org.eclipse.products.epp.package.javascript.2020-06
Workspace /home/b/dev/eclipsews
Bundle org.eclipse.oomph.setup 1.19.0.v20210223-0655, build=5032, branch=de1d74a6bf3addd102f8a873eabac293fbeaa3ad
Bundle org.eclipse.oomph.setup.core 1.20.0.v20210411-0650, build=5073, branch=1c11e00dca919bce9f672d8aae11ec1c2af4d45a
Bundle org.eclipse.oomph.setup.p2 1.16.0.v20200814-1205, build=4821, branch=9bc46599ffa5e6ffd3e2d2122913fe40d711f2f5
Performing P2 Director (Eclipse IDE for JavaScript and Web Developers (2020-06))
Offline = false
Mirrors = false
Resolving 17 requirements from 3 repositoriesto /home/b/eclipse/javascript-2020-06/eclipse
Requirement org.eclipse.equinox.p2.iu:epp.package.javascript [4.16.0,5.0.0)
Requirement org.eclipse.equinox.p2.iu:org.eclipse.platform.feature.group [4.16.0,5.0.0)
Requirement org.eclipse.equinox.p2.iu:org.eclipse.rcp.feature.group [4.16.0,5.0.0)
Requirement org.eclipse.equinox.p2.iu:org.eclipse.egit.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.egit.gitflow.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.epp.mpc.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.epp.package.common.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.equinox.p2.user.ui.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.help.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.mylyn.wikitext_feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.rse.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.tips.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.tm.terminal.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.wildwebdeveloper.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.wst.server_adapters.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.wst.server_ui.feature.feature.group
Requirement org.eclipse.equinox.p2.iu:org.eclipse.oomph.setup.feature.group
Repository http://download.eclipse.org/technology/epp/packages/2020-06
Repository http://download.eclipse.org/releases/2020-06/202006171000
Repository http://download.eclipse.org/oomph/updates/milestone/latest
Adding repository http://download.eclipse.org/technology/epp/packages/2020-06
Adding repository http://download.eclipse.org/releases/2020-06/202006171000
Adding repository http://download.eclipse.org/oomph/updates/milestone/latest
Calculating requirements and dependencies.
Cannot complete the request. Generating details.
ERROR: org.eclipse.equinox.p2.director code=10054 Cannot complete the install because of a conflicting dependency.
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:291)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.resolve(ProfileTransactionImpl.java:428)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:340)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:899)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3851)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.access$1(SetupTaskPerformer.java:3794)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil$1.run(SetupTaskPerformer.java:5160)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2292)
at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2317)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.performNeededSetupTasks(SetupTaskPerformer.java:5154)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer$WorkspaceUtil.access$0(SetupTaskPerformer.java:5152)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3785)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3760)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3638)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:595)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:722)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
ERROR: org.eclipse.equinox.p2.director code=0 Software being installed: artificial_root 1.0.0.v1618253623015
ERROR: org.eclipse.equinox.p2.director code=1 Only one of the following can be installed at once:
ERROR: org.eclipse.equinox.p2.director code=0 Ant Build Tool Core 3.5.800.v20200608-1251 (org.eclipse.ant.core 3.5.800.v20200608-1251)
ERROR: org.eclipse.equinox.p2.director code=0 Ant Build Tool Core 3.5.700.v20191221-1203 (org.eclipse.ant.core 3.5.700.v20191221-1203)
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1618253623015
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; epp.package.javascript [4.16.0,5.0.0)
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: artificial_root 1.0.0.v1618253623015
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.wildwebdeveloper.product 0.11.6.202103151818
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse IDE for JavaScript and Web Developers (includes incubating components) 4.16.0.20200615-1200 (epp.package.javascript 4.16.0.20200615-1200)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.16.0.v20200604-0951,4.16.0.v20200604-0951]
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse Platform 4.16.0.v20200604-0951 (org.eclipse.platform.feature.group 4.16.0.v20200604-0951)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.ant.core [3.5.700.v20191221-1203,3.5.700.v20191221-1203]
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse Platform 4.19.0.v20210303-1800 (org.eclipse.platform.feature.group 4.19.0.v20210303-1800)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.ant.core [3.5.800.v20200608-1251,3.5.800.v20200608-1251]
ERROR: org.eclipse.equinox.p2.director code=1 Cannot satisfy dependency:
ERROR: org.eclipse.equinox.p2.director code=0 From: Eclipse IDE for JavaScript and Web Developers 0.11.6.202103151818 (org.eclipse.wildwebdeveloper.product 0.11.6.202103151818)
ERROR: org.eclipse.equinox.p2.director code=0 To: org.eclipse.equinox.p2.iu; org.eclipse.platform.feature.group [4.19.0.v20210303-1800,4.19.0.v20210303-1800]

Took 2 seconds.
There are failed tasks.
Press Back to choose different settings or Cancel to abort.
  • Attachment: Error 1.png
    (Size: 23.21KB, Downloaded 15 times)
Re: P2 Director Problem [message #1840354 is a reply to message #1840337] Tue, 13 April 2021 06:18 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31957
Registered: July 2009
Senior Member
From what I see here, this is a 2020-06 version or is trying to update to a 2020-06 version.

The dialog that comes up has a prompt that you can say "no don't do this" and also "remember not to do this again". One problem in general with updating this IDE at all is that epp.package.javascript is not in the 2021-03 release so you won't be able to update to a new version of that.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: P2 Director Problem [message #1840363 is a reply to message #1840354] Tue, 13 April 2021 08:31 Go to previous messageGo to next message
B Whitehead is currently offline B WhiteheadFriend
Messages: 4
Registered: April 2021
Junior Member
Thanks for the response Ed, but I am not clear what the solution is, can you humour me with answering a couple of more questions?

Bear in mind that I know little about Eclipse itself, I just use it as a tool. When I open it, it declares itself as 2021-03 on the splash screen.

Are you suggesting I just ignore the message and wait for the versions to catch up, or should I do a completely fresh install to ensure everything matches?

Is this connected with the other issue where now, each time I try to open a .css file, Eclipse freezes such that I have to force it to close?

Thanks for your patience with a newbie.

Regards

Brian
Re: P2 Director Problem [message #1840365 is a reply to message #1840363] Tue, 13 April 2021 09:11 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31957
Registered: July 2009
Senior Member
So your IDE probably updated at least some parts to 2021-03. But the folder name '/home/b/eclipse/javascript-2020-06/eclipse' suggests the installation itself is a year old...

The initial message, if I understand it correctly, just comes up because what you have installed doesn't match the product catalog entry that was used to create the installation. It's okay to ignore that and do your updates manually using Help -> Check for Updates...

If I were you, I would try to just create a new 2021-03 installation from scratch and see if that one works better. You'll most likely want "Eclipse IDE for Enterprise Java and Web Developers" given the Java Script package was removed.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: P2 Director Problem [message #1840366 is a reply to message #1840365] Tue, 13 April 2021 09:15 Go to previous message
B Whitehead is currently offline B WhiteheadFriend
Messages: 4
Registered: April 2021
Junior Member
OK, I'll do that.

Thanks for your help Ed.

Regards

Brian
Previous Topic:Is possible to add JavaScript tools to my php IDE?
Next Topic:Icons are missing in the Eclipse IDE Help
Goto Forum:
  


Current Time: Sun Jul 25 01:08:11 GMT 2021

Powered by FUDForum. Page generated in 0.02969 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top