Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Support for p2 update sites from maven in target platforms editor(Target Platform, Maven)
Support for p2 update sites from maven in target platforms editor [message #1839870] Tue, 30 March 2021 16:01 Go to next message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 97
Registered: July 2009
Member
Hi,

In the recent Tycho release (2.2.0) there is mention of support for update sites located in maven repository (https://wiki.eclipse.org/Tycho/Release_Notes/2.2#Support_for_consuming_maven_artifacts_made_of_zipped_P2_update_sites).

It is said that it is supported in target platform as well.

Building with Tycho seems to work fine when the update site is referenced in the target platform.

But in the target platform editor, or when I try to load it from the UI I am getting this error:

Unable to read repository at mvn:***:***:1.1.0-SNAPSHOT:zip/content.xml.


How is the support in the UI, is it working yet or is it only supported during tycho build?

Thanks.

[Updated on: Tue, 30 March 2021 19:11]

Report message to a moderator

Re: Support for p2 update sites from maven in target platforms editor [message #1839886 is a reply to message #1839870] Wed, 31 March 2021 07:06 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32033
Registered: July 2009
Senior Member
Did you install the latest version of the IDE. There are features in PDE new to 2021-03 that would need to be installed.

You might ask about it on the Tycho mailing list because the person who developed this watches that list:

https://dev.eclipse.org/mailman/listinfo/tycho-user


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Support for p2 update sites from maven in target platforms editor [message #1839913 is a reply to message #1839886] Wed, 31 March 2021 21:56 Go to previous message
Guillaume Hillairet is currently offline Guillaume HillairetFriend
Messages: 97
Registered: July 2009
Member
Yes I did install the last version.
I will ask in the mailing list.

Thanks
Previous Topic:[Help] (SWT:5152): Gtk-WARNING ?
Next Topic:Unable to connect to the network for update
Goto Forum:
  


Current Time: Tue Sep 28 11:42:22 GMT 2021

Powered by FUDForum. Page generated in 0.02438 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top