Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » Error compiling on freeRTOS+lwip(undefined reference to 'xxx')
Error compiling on freeRTOS+lwip [message #1838888] Mon, 08 March 2021 07:45 Go to next message
Jizhi Lee is currently offline Jizhi LeeFriend
Messages: 4
Registered: March 2021
Junior Member
rookie to cmake...
I followed the steps according to http://https://www.eclipse.org/4diac/en_help.php?helppage=html/installation/freeRTOSLwIP.html
and I think I have got the correct FORTE_FreeRTOSLwIP_INCLUDES path... seems like that.
But the result came out
[ 99%] Linking CXX executable forte
/opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.3.0/ARMTools/bin/../lib/gcc/arm-atollic-eabi/6.3.1/../../../../arm-atollic-eabi/bin/ld: warning: cannot find entry symbol _start; defaulting to 0000000000008018
/opt/Atollic_TrueSTUDIO_for_STM32_x86_64_9.3.0/ARMTools/bin/../lib/gcc/arm-atollic-eabi/6.3.1/../../../../arm-atollic-eabi/lib/libc.a(lib_a-exit.o): In function `exit':
exit.c:(.text.exit+0x2c): undefined reference to `_exit'
CMakeFiles/forte.dir/arch/freeRTOS/main.cpp.obj: In function `vForteTask(void*)':
main.cpp:(.text+0x90): undefined reference to `vTaskDelete'
CMakeFiles/forte.dir/arch/freeRTOS/main.cpp.obj: In function `vStartForteServerTask(unsigned long)':
main.cpp:(.text+0xe8): undefined reference to `xTaskCreate'
CMakeFiles/forte.dir/arch/freeRTOS/main.cpp.obj: In function `main':
main.cpp:(.text+0x114): undefined reference to `vTaskStartScheduler'
...


and my project is created by STM32CUBEMX, developing with trueStudio IDE.
Thanks in advance!!Please~ :D

[Updated on: Mon, 08 March 2021 14:53]

Report message to a moderator

Re: Error compiling on freeRTOS+lwip [message #1838901 is a reply to message #1838888] Mon, 08 March 2021 20:26 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1212
Registered: January 2014
Senior Member
It seems that you are missing some libraries for linking your executable.
Re: Error compiling on freeRTOS+lwip [message #1838908 is a reply to message #1838901] Tue, 09 March 2021 05:49 Go to previous messageGo to next message
Jizhi Lee is currently offline Jizhi LeeFriend
Messages: 4
Registered: March 2021
Junior Member
Okay.
I found the problem is that I didn't set FORTE_BUILD_EXECUTABLE to false, and this option is hidden in my defalut cmake setting.
My cmake-gui version is 3.16.3, and you should set the Advanced flag to true then the FORTE_BUILD_EXECUTABLE flag will come out.
Anyway, it works now :D
[ 50%] Built target forte_stringlist_generator
[100%] Built target FORTE_LITE
Scanning dependencies of target forte-static
[100%] Linking CXX static library libforte-static.a
[100%] Built target forte-static

Thanks for help!
Re: Error compiling on freeRTOS+lwip [message #1838914 is a reply to message #1838908] Tue, 09 March 2021 08:18 Go to previous message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1212
Registered: January 2014
Senior Member
thanks for letting us know. Maybe we need to improve here on our cmake settings.
Previous Topic:Publish FB Inhibited
Next Topic:Eventqueue runs full
Goto Forum:
  


Current Time: Sat May 15 06:14:19 GMT 2021

Powered by FUDForum. Page generated in 0.02172 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top