Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Eclipse RCP: Error when exporting Sample Eclipse Product(RCP product export error)
Eclipse RCP: Error when exporting Sample Eclipse Product [message #1838430] Wed, 24 February 2021 18:48 Go to next message
Vadim Chesnokov is currently offline Vadim ChesnokovFriend
Messages: 2
Registered: February 2021
Junior Member
I've set up jdk-15.0.2+7 from AdoptOpenJDK. I've set up Eclipse IDE for RCP and RAP Developers (version: 2020-12 (4.18.0), Build id: 20201210-1552). I started Eclipse, created Plug-in Project PortfolioAnalyzer with default settings:

Target platform: Eclipse,
Create a rich client application? Yes
Plug-in Template: Eclipse 4 RCP Application
Checkbox Create sample content (part, menu, command...): True
Then I


  • open PortfolioAnalyzer.product with default Product Configuration Editor, tab Overview and click link Eclipse Product export wizard in Exporting section
  • specify Destination directory: D:\rcp_out, all settings by default.


And get error:

D:\Work\Eclipse\Java\PortfolioAnalyzer\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\package.org.eclipse.pde.container.feature.win32.win32.x86_64.xml:477: The following error occurred while executing this line:
C:\Users\Vadim\.p2\pool\plugins\org.eclipse.pde.build_3.10.900.v20201111-1557\scripts\genericTargets.xml:240: A problem occured while invoking the director.
The following error occurred while executing this line:
D:\Work\Eclipse\Java\PortfolioAnalyzer\.metadata\.plugins\org.eclipse.pde.core\temp\org.eclipse.pde.container.feature\package.org.eclipse.pde.container.feature.win32.win32.x86_64.xml:477: The following error occurred while executing this line:
C:\Users\Vadim\.p2\pool\plugins\org.eclipse.pde.build_3.10.900.v20201111-1557\scripts\genericTargets.xml:240: A problem occured while invoking the director.


I've edited C:\Users\Vadim\.p2\pool\plugins\org.eclipse.pde.build_3.10.900.v20201111-1557\scripts\genericTargets.xml
by adding in target runDirector the following line just after properties definitions:
<record name="d:/build.log" loglevel="verbose" append="false"/>

In the case I get the log file when the error occurs. This is its content:
Property "p2.director.log" has not been set
[p2.director] Installing App 1.0.0.202102120000.
[p2.director] Installation failed.
[p2.director] Cannot complete the install because one or more required items could not be found.
[p2.director] Software being installed: PortfolioAnalyzer 1.0.0.202102120000 (App 1.0.0.202102120000)
[p2.director] Missing requirement: PortfolioAnalyzer 1.0.0.202102120000 (PortfolioAnalyzer 1.0.0.202102120000) requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=15))' but it could not be found
[p2.director] Cannot satisfy dependency:
[p2.director] From: PortfolioAnalyzer 1.0.0.202102120000 (App 1.0.0.202102120000)
[p2.director] To: org.eclipse.equinox.p2.iu; PortfolioAnalyzer [1.0.0.202102120000,1.0.0.202102120000]
[p2.director] Cannot complete the install because one or more required items could not be found.
[p2.director] Software being installed: PortfolioAnalyzer 1.0.0.202102120000 (App 1.0.0.202102120000)
[p2.director] Missing requirement: PortfolioAnalyzer 1.0.0.202102120000 (PortfolioAnalyzer 1.0.0.202102120000) requires 'osgi.ee; (&(osgi.ee=JavaSE)(version=15))' but it could not be found
[p2.director] Cannot satisfy dependency:
A problem occured while invoking the director.
runDirector: duration 0 seconds


Could you explain how to fix the problem? Should p2.director.log property be set somehow? Or something wrong with org.eclipse.equinox.p2.iu?
Re: Eclipse RCP: Error when exporting Sample Eclipse Product [message #1838528 is a reply to message #1838430] Sat, 27 February 2021 20:12 Go to previous message
Vadim Chesnokov is currently offline Vadim ChesnokovFriend
Messages: 2
Registered: February 2021
Junior Member
It's very strange that examples embedded in Eclipse don't work and nobody knows how to fix it.
Previous Topic:How to set up a remote Docker development environment
Next Topic:Launch fails on one computer but succeeds on another
Goto Forum:
  


Current Time: Mon Apr 19 20:06:35 GMT 2021

Powered by FUDForum. Page generated in 0.01585 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top