Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Creation tool uses tool name instead of label for command label?
Creation tool uses tool name instead of label for command label? [message #1837654] Wed, 03 February 2021 16:51 Go to next message
Felix Dorner is currently offline Felix DornerFriend
Messages: 391
Registered: December 2015
Senior Member
Hi,

I'm working with Sirius for a long time now and I have just noticed, that creation commands (e.g. when I create a container/node in a diagram), the Edit->Undo menu shows the name of the tool, not the label of the tool. I'm suspicious if that has always been the case or if there is a regression? I didn't expect identifiers to leak into the UI. This is with Sirius 6.3.3.


Re: Creation tool uses tool name instead of label for command label? [message #1837744 is a reply to message #1837654] Fri, 05 February 2021 07:52 Go to previous message
Florian Barbin is currently offline Florian BarbinFriend
Messages: 262
Registered: August 2010
Senior Member
Hi Felix,

From what I see in org.eclipse.sirius.diagram.tools.internal.command.builders.NodeCreationCommandBuilder.getEnclosingCommandLabel() for instance, it confirms that we use the tool name as the command name. This code has not changed recently.

Regards,
Florian
Previous Topic:BorderedNode Label not shown after creation
Next Topic:Arranging all nodes according to grid
Goto Forum:
  


Current Time: Sun Apr 18 20:01:43 GMT 2021

Powered by FUDForum. Page generated in 0.01505 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top