Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Issue with mdt-ocl-Update sites
Issue with mdt-ocl-Update sites [message #1837555] Tue, 02 February 2021 10:20 Go to next message
houda houda is currently offline houda houdaFriend
Messages: 12
Registered: February 2021
Junior Member
Hello,
I've been trying to install the Eclipse OCL (Object Constraint Language) 2020-06 (6.12.0), which is supposedly compatible with my Eclipse IDE 2020-06.
I tried the following update site
https://www.eclipse.org/downloads/download.php?file=/modeling/mdt/ocl/downloads/drops/6.12.0/R202006081555/mdt-ocl-Update-6.12.0.zip, and I also tried to download it in Zip form and install it on my Eclipse, however, I keep getting the following errors (check bellow).
I would like to know what am I doing wrong, and how can I fix that?
Thanks in advance.
*******************
An error occurred while collecting items to be installed
session context was:(profile=C__Users_nouno_eclipse_java-2019-12_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.emf.codegen,2.21.0.v20200708-0547
No repository found containing: osgi.bundle,org.eclipse.emf.codegen.ecore,2.24.0.v20200917-1423
No repository found containing: osgi.bundle,org.eclipse.emf.common,2.21.0.v20200917-1439
No repository found containing: osgi.bundle,org.eclipse.emf.ecore,2.23.0.v20200630-0516
No repository found containing: osgi.bundle,org.eclipse.emf.edit.ui,2.19.0.v20200917-1406
No repository found containing: org.eclipse.update.feature,org.eclipse.emf.common,2.21.0.v20200917-1439
No repository found containing: org.eclipse.update.feature,org.eclipse.emf.ecore,2.23.0.v20200630-0516
No repository found containing: osgi.bundle,org.eclipse.emf.mwe.core,1.6.0.v20201119-2018
No repository found containing: osgi.bundle,org.eclipse.emf.mwe2.runtime,2.12.0.v20201119-2018
No repository found containing: osgi.bundle,org.eclipse.pde.build,3.10.900.v20201111-1557
No repository found containing: osgi.bundle,org.eclipse.pde.core,3.14.100.v20201116-1221
No repository found containing: osgi.bundle,org.eclipse.xtend.lib,2.24.0.v20201130-0911
No repository found containing: osgi.bundle,org.eclipse.xtend.lib.macro,2.24.0.v20201130-0911
No repository found containing: osgi.bundle,org.eclipse.xtext,2.24.0.v20201130-0914
No repository found containing: osgi.bundle,org.eclipse.xtext.builder,2.24.0.v20201130-0931
No repository found containing: osgi.bundle,org.eclipse.xtext.common.types,2.24.0.v20201130-0919
No repository found containing: osgi.bundle,org.eclipse.xtext.common.types.edit,2.24.0.v20201130-0931
No repository found containing: osgi.bundle,org.eclipse.xtext.common.types.ui,2.24.0.v20201130-0931
No repository found containing: osgi.bundle,org.eclipse.xtext.ide,2.24.0.v20201130-0914
No repository found containing: osgi.bundle,org.eclipse.xtext.smap,2.24.0.v20201130-0919
No repository found containing: osgi.bundle,org.eclipse.xtext.ui,2.24.0.v20201130-0931
No repository found containing: osgi.bundle,org.eclipse.xtext.ui.shared,2.24.0.v20201130-0931
No repository found containing: osgi.bundle,org.eclipse.xtext.util,2.24.0.v20201130-0914
No repository found containing: osgi.bundle,org.eclipse.xtext.xbase.lib,2.24.0.v20201130-0911
No repository found containing: osgi.bundle,org.objectweb.asm,9.0.0.v20201001-1419
Re: Issue with mdt-ocl-Update sites [message #1837583 is a reply to message #1837555] Tue, 02 February 2021 19:21 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7665
Registered: July 2009
Senior Member
HI

You don#t say how you installed, but it looks like you did not use the simple approach of Help->Install New Software that will offer the prevailing SimRel and all its dependencies.

The number of unfindable versions greater than 2020-06 strongly suggests that at least one non 2020-06 contribution is corrupting your install. Help->About Eclipse->Installation Details may give you a clue as to what you forgot you had installed.

If you really used Help->Install New Software then Eclipse may have a problem that the SimRel repo has been polluted.

If you want to just fudge/fix your install use the 2020-12 release which should have the more recent dependencies.

Regards

Ed Willink
Re: Issue with mdt-ocl-Update sites [message #1837589 is a reply to message #1837583] Tue, 02 February 2021 20:38 Go to previous messageGo to next message
houda houda is currently offline houda houdaFriend
Messages: 12
Registered: February 2021
Junior Member
Hello Ed.
Thanks for your answer,
I would like to mention that I actually used the help>install new software to install the OCL package, however, it still didn't work.
I have checked the installation details to inspect any installations that are non 2020-06 contribution. I found the following installation, which is 2020-07 if I'm not wrong (check the figure below).

index.php/fa/39891/0/

However, I can't figure how to replace/update it to be compatible with my current Eclipse version, as I don't wish to update my Eclipse right now, if it is possible.
  • Attachment: capt.png
    (Size: 90.29KB, Downloaded 354 times)
Re: Issue with mdt-ocl-Update sites [message #1837605 is a reply to message #1837589] Wed, 03 February 2021 06:02 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7665
Registered: July 2009
Senior Member
Hi

You only show the bottom half of your install list. Your OOMPH install is only one week after 2020-06 and while it uses EMF, I wouldn't have expected EMF to move on that rapidly; it is probably just a bug fix. However post 2012-06 we start the nightmare of moving on from Java 8 that prevented an 2020-09 release of OCL. It may be that OOMPH has started something that depends on something that is affected by the Java 11 migration.

Regards

Ed Willink
Previous Topic:Generate Java code for generic classes
Next Topic:OCL expression not evaluated
Goto Forum:
  


Current Time: Tue Jul 23 16:08:21 GMT 2024

Powered by FUDForum. Page generated in 0.03730 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top