Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » 4DIAC - Framework for Distributed Industrial Automation and Control » error using "save as subapplication type" on more than one subapplication - 4diac 1.13(error using "save as subapplication type" on more than one subapplication - 4diac 1.13)
error using "save as subapplication type" on more than one subapplication - 4diac 1.13 [message #1836459] Mon, 04 January 2021 19:18 Go to next message
Felix Böseler is currently offline Felix BöselerFriend
Messages: 9
Registered: November 2020
Junior Member
Hello,

When I create two subapplications (subapps) as in "untyped-subapps.png" and then use "save as subapplication type" with a right click on both subapps (sequentially) I get correct typed subapps as seen in "type-subapps.png". However, after a restart one typed subapp gets reset to the default interface and is empty as seen in picture "typed-subapps-error.png".

Am I using the "save as subapplication type" function wrong or could this be a bug?

Many thanks in advance,

Felix B.

[Updated on: Fri, 08 January 2021 13:50]

Report message to a moderator

Re: error using "save as subapplication type" on more than one subapplication - 4diac 1.13 [message #1836462 is a reply to message #1836459] Mon, 04 January 2021 19:55 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1214
Registered: January 2014
Senior Member
This look very strange. Can you send us the resulting .sub files for inspection?
Re: error using "save as subapplication type" on more than one subapplication - 4diac 1.13 [message #1836595 is a reply to message #1836462] Fri, 08 January 2021 11:12 Go to previous messageGo to next message
Felix Böseler is currently offline Felix BöselerFriend
Messages: 9
Registered: November 2020
Junior Member
I have uploaded the files in the original message. The files that end with "before" refer to the files before the restart and "after" after the restart. I hope this helps.
Re: error using "save as subapplication type" on more than one subapplication - 4diac 1.13 [message #1836596 is a reply to message #1836595] Fri, 08 January 2021 11:35 Go to previous messageGo to next message
Alois Zoitl is currently offline Alois ZoitlFriend
Messages: 1214
Registered: January 2014
Senior Member
wow it really looks like that the first version is generated wrongly. In your workspace there is a .metadata directory and there a .log file. would you mind sending us that as well?
Re: error using "save as subapplication type" on more than one subapplication - 4diac 1.13 [message #1836598 is a reply to message #1836596] Fri, 08 January 2021 13:51 Go to previous message
Felix Böseler is currently offline Felix BöselerFriend
Messages: 9
Registered: November 2020
Junior Member
I replicated this error in a new workspace and uploaded two snapshots of the complete workspace as zip packages (upload in the original question). The "before.zip" was taken after I created the subapp types and assigned them to the previously untyped subapps. The snapshot was taken while the IDE was running. After that I restarted the IDE. The second snapshot was taken right after the restart.
Previous Topic:Unable to use debug watch on blocks inside a typed subapplication - 4diac 1.13
Next Topic:Error compiling forte 1.13 with open62 1.0.5
Goto Forum:
  


Current Time: Tue May 18 13:21:30 GMT 2021

Powered by FUDForum. Page generated in 0.02451 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top