Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » How to select specific OSGI bundles to run in Eclipse(How to select specific OSGI bundles to run in Eclipse)
How to select specific OSGI bundles to run in Eclipse [message #1836280] Mon, 28 December 2020 05:39 Go to next message
Tunde Lawal is currently offline Tunde LawalFriend
Messages: 2
Registered: December 2020
Junior Member
Hello everyone, am a MSc. student who is learning to use OSGI. I want to choose a specific OSGI bundle and org.eclipse.equinox.ds bundle in eclipse. I want to run these two bundles together. Am trying to implement OSGI Declarative Services using Equinox in eclipse. How can I use eclipse to run these two bundles? I have tried running with configuration but I don't know how to locate these bundles from eclipse and the setting to choose to achieve my aim. Thanks in advance for any help.
Re: How to select specific OSGI bundles to run in Eclipse [message #1836975 is a reply to message #1836280] Wed, 20 January 2021 12:33 Go to previous messageGo to next message
Mark Smith is currently offline Mark SmithFriend
Messages: 84
Registered: September 2020
Member
Please check this one
https://www.vogella.com/tutorials/OSGi/article.html
Re: How to select specific OSGI bundles to run in Eclipse [message #1836984 is a reply to message #1836975] Wed, 20 January 2021 14:56 Go to previous message
Tunde Lawal is currently offline Tunde LawalFriend
Messages: 2
Registered: December 2020
Junior Member
Got it, thanks a lot.
Previous Topic:Annotation processing type element look-up problem with Java 9 or later
Next Topic:Java 15 support plugin for eclipse 2020-09 not available
Goto Forum:
  


Current Time: Tue Apr 20 14:54:28 GMT 2021

Powered by FUDForum. Page generated in 0.01575 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top