Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012
RCPTT 2.5.1 couldn't start AUT based on eclipse (4.18) 202012 [message #1836025] Fri, 18 December 2020 12:58
lea ilagan is currently offline lea ilaganFriend
Messages: 59
Registered: October 2012
Member
Hello,

Please advise. Is RCPTT 2.5.1 compatible with eclipse 202012?
I tried to use 202009 and i was able to start(launch) after updating AUT runtime to JRE 11.

However, it did not work in eclipse 202012.

Here's snippet of console.log, i attached the complete log.

OpenJDK 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0
!SESSION 2020-12-18 07:52:59.953 -----------------------------------------------
eclipse.buildId=4.18.0.I20201202-1800
java.version=11.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.platform.ide -eclipse.keyring C:\Testing\RCPTT\IDE\ws-2.5.1-4\.metadata\.plugins\org.eclipse.pde.core\org.eclipse.platform.ide/secure_storage
Command-line arguments:  -product org.eclipse.platform.ide -data C:\Testing\RCPTT\IDE\ws-2.5.1-4/../aut-org.eclipse.platform.ide -dev file:C:/Testing/RCPTT/IDE/ws-2.5.1-4/.metadata/.plugins/org.eclipse.pde.core/org.eclipse.platform.ide/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog -eclipse.keyring C:\Testing\RCPTT\IDE\ws-2.5.1-4\.metadata\.plugins\org.eclipse.pde.core\org.eclipse.platform.ide/secure_storage

!ENTRY org.eclipse.emf.ant 4 0 2020-12-18 07:53:02.619
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.ant [100]
  Unresolved requirement: Require-Bundle: org.eclipse.emf.codegen.ecore; bundle-version="[2.9.0,3.0.0)"; resolution:="optional"
    -> Bundle-SymbolicName: org.eclipse.emf.codegen.ecore; bundle-version="2.9.1.v20140203-1126"; singleton:="true"
       org.eclipse.emf.codegen.ecore [102]
         Unresolved requirement: Require-Bundle: org.eclipse.jdt.core; bundle-version="[3.5.0,4.0.0)"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.codegen; bundle-version="[2.9.0,3.0.0)"
    -> Bundle-SymbolicName: org.eclipse.emf.codegen; bundle-version="2.9.0.v20140203-1126"; singleton:="true"
       org.eclipse.emf.codegen [101]
         Unresolved requirement: Require-Bundle: org.eclipse.jdt.core; bundle-version="[3.5.0,4.0.0)"

	at org.eclipse.osgi.container.Module.start(Module.java:463)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845)
	at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1779)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345)
  • Attachment: console.log
    (Size: 72.08KB, Downloaded 55 times)
Previous Topic:Containerized RCPTT test execution
Next Topic:Eclipse does not display my project files on project explorer
Goto Forum:
  


Current Time: Sun Feb 25 16:43:37 GMT 2024

Powered by FUDForum. Page generated in 0.02328 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top