Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Installation Error(Error while installing Eclipse)
Installation Error [message #1835791] Sun, 13 December 2020 02:26 Go to next message
Aqeel Muhammad is currently offline Aqeel MuhammadFriend
Messages: 1
Registered: December 2020
Junior Member
An error was detected while performing the engine operation and the changes are being rolled back. See the log for details.
ERROR: org.eclipse.equinox.p2.engine code=4 An error occurred while installing the items
at org.eclipse.oomph.util.OomphPlugin.coreException(OomphPlugin.java:291)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl$3.commit(ProfileTransactionImpl.java:551)
at org.eclipse.oomph.p2.internal.core.ProfileTransactionImpl.commit(ProfileTransactionImpl.java:343)
at org.eclipse.oomph.setup.p2.impl.P2TaskImpl.perform(P2TaskImpl.java:899)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.doPerformNeededSetupTasks(SetupTaskPerformer.java:3828)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performNeededSetupTasks(SetupTaskPerformer.java:3756)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.performTriggeredSetupTasks(SetupTaskPerformer.java:3737)
at org.eclipse.oomph.setup.internal.core.SetupTaskPerformer.perform(SetupTaskPerformer.java:3630)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$9.run(ProgressPage.java:593)
at org.eclipse.oomph.setup.ui.wizards.ProgressPage$11$1.run(ProgressPage.java:720)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:63)
ERROR: org.eclipse.equinox.p2.engine code=0 session context was:(profile=C__Users_ASUS_java-2020-09_eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.platform.ide.executable.win32.win32.x86_64 4.17.0.I20200902-1800, action=org.eclipse.equinox.internal.p2.touchpoint.natives.actions.UnzipAction).
ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The artifact for binary,org.eclipse.platform.ide.executable.win32.win32.x86_64,4.17.0.I20200902-1800 is not available.




How to fix this error
Re: Installation Error [message #1835796 is a reply to message #1835791] Sun, 13 December 2020 14:27 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32111
Registered: July 2009
Senior Member
The error suggests that your bundle pool is corrupted, either because a corrupt artifact was downloaded or your virus scanner block the moving of that file after it was downloaded.

Please refer to this page for how to repair the pool:

https://www.eclipse.org/setups/installer/question/

In particular this:

Use the eclipse installer's bundle pools... menu item to manage where this pool is physically located on disk; this location can become large. The bundle pool Management dialog supports garbage collecting of unused artifacts, i.e., if you delete an installation, the artifacts it uses can potentially be removed from disk. In addition, if some artifact becomes corrupted, or if a corrupted artifact is downloaded from some mirror site, this dialog can be used to detect the damage and to repair it.

Please let me know if that help fix the problem.


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Form-based authentication with gitlab 13.6.1 not working because of missing closing tag for "me
Next Topic:Installer fails
Goto Forum:
  


Current Time: Tue Dec 07 13:17:38 GMT 2021

Powered by FUDForum. Page generated in 0.02349 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top