Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Edges display - Bug / Missing feature (Poor edge representational capability when connected to container)
Edges display - Bug / Missing feature [message #1835383] Wed, 02 December 2020 06:32 Go to next message
Avi Shaked is currently offline Avi ShakedFriend
Messages: 122
Registered: October 2019
Senior Member
Hi,

I am experiencing a problem in achieving a desired behavior for edges representation my workbench. When I use an element based edge between regular nodes with "Straight" routing style, the designer (user of my workbench) can change the routing by dragging the lines, adding "bend-points". I consider this a desired behavior.
However, when the edge - with same definitions - is connected to a container instead of a regular node, the user is not able to create these bend-points, and the edge line is forced to be straight.

I am attaching a screenshot, as well as a very simple demo model to illustrate this.

Can this be opened as a bug? (so that the edge representation when using containers will allow adding bendpoints)
Is there a way to by-pass the problem and create bend-points for the container-related edges?

Thank you,
Avi
  • Attachment: demo1edge.png
    (Size: 80.18KB, Downloaded 16 times)
  • Attachment: demo1.zip
    (Size: 141.85KB, Downloaded 11 times)

[Updated on: Wed, 02 December 2020 06:33]

Report message to a moderator

Re: Edges display - Bug / Missing feature [message #1835489 is a reply to message #1835383] Fri, 04 December 2020 15:43 Go to previous messageGo to next message
Steve Monnier is currently offline Steve MonnierFriend
Messages: 508
Registered: May 2011
Senior Member
Hello,

Indeed, this looks like an issue. You can file a new bugzilla, thank you.
Strangely, when I change the edges to a rectilnear or tree routing style (in the "appearance" tab of the properties view), I can't set it back to the Oblique routing style. There is definitely something fishy here.

Best regards,
Steve


Steve Monnier - Obeo
Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Edges display - Bug / Missing feature [message #1835534 is a reply to message #1835489] Sun, 06 December 2020 05:24 Go to previous message
Avi Shaked is currently offline Avi ShakedFriend
Messages: 122
Registered: October 2019
Senior Member
Thanks Steve!
Previous Topic:background color of Project explorer in eclipse
Next Topic:Is there a way to support UML Aggregation in Sirius?
Goto Forum:
  


Current Time: Sun Apr 18 09:15:42 GMT 2021

Powered by FUDForum. Page generated in 0.02197 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top