Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Breakpoint in debugged application doesn't show source file, after upgrade to 2020-03?
Breakpoint in debugged application doesn't show source file, after upgrade to 2020-03? [message #1834909] Fri, 20 November 2020 09:40 Go to next message
MadisonWyatt MadisonWyatt is currently offline MadisonWyatt MadisonWyattFriend
Messages: 1
Registered: November 2020
Junior Member
I've been using 2019-12 since the release, and just upgraded to 2020-03 yesterday.

I run in debug our Maven SpringBoot applications quite often. Stepping through the code works perfectly fine, before today.

Today I ran one application in debug that I've run many times. It started up fine, but when it hit a breakpoint that I set, it was not able to find the source. I inspected the run configuration, and it specifies the correct project. The project itself looks like a normal Maven project in the package explorer. It shows the correct source folders, and there are no errors.

I even tried clicking "Edit Source Lookup Path". The "Default" entry has all the maven dependencies and one folder that we always manually add to our springboot run configurations (a folder with additional properties files). There were no source folders. I then manually added the project to the source lookup and inspected the result. It appeared to have all the relevant folders from that project. However, even after I closed the editor window for the file and reopened it from the stack entry, it still said it can't find the source file.

I checked the error log. I saw a string of exceptions about a hover problem in Spring IDE (which I will report), but nothing that would cause the problem I'm seeing.


Re: Breakpoint in debugged application doesn't show source file, after upgrade to 2020-03? [message #1835016 is a reply to message #1834909] Mon, 23 November 2020 13:21 Go to previous message
Sarika Sinha is currently offline Sarika SinhaFriend
Messages: 122
Registered: February 2010
Location: Bangalore, India
Senior Member
Hi,
This sounds like https://bugs.eclipse.org/bugs/show_bug.cgi?id=559797.
Can you try 2020-06 release ?


Sarika Sinha
JDT Programmer
Previous Topic:main class not found
Next Topic:Eclipse IDE: for Java EE Developers vs for Java Developers
Goto Forum:
  


Current Time: Thu Aug 05 22:31:59 GMT 2021

Powered by FUDForum. Page generated in 0.05880 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top