Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » APP4MC » Error: No model loaded! in IndexExample(From folder /app4mc.example.tool.java)
Error: No model loaded! in IndexExample [message #1834586] Fri, 13 November 2020 00:28 Go to next message
ruby Shih is currently offline ruby ShihFriend
Messages: 1
Registered: November 2020
Junior Member
Hello everyone,

When I try to run the class IndexExample, it shows "Error: No model loaded!".
I'm new to eclipse/java and haven't had clue how to deal with it.
I want to load the existed amalthea model to the program.

The compiler complience is 1.8 and jre is 8.
The version of AMLTHEA model is 1.0.0 and org.eclipse.app4mc.amalthea.model is 0.9.9.
It would be nice if you can give me some advices.

Thank you and best regards,
Ruby

[Updated on: Fri, 13 November 2020 08:26]

Report message to a moderator

Re: Error: No model loaded! in IndexExample [message #1835048 is a reply to message #1834586] Tue, 24 November 2020 00:31 Go to previous message
Henning Riedel is currently offline Henning RiedelFriend
Messages: 310
Registered: July 2009
Senior Member
How come, your Amalthea model (the amxmi file) is 1.0.0, but your o.e.app4mc.amalthea.model (plugin?) is just 0.9.9?

If you use the 0.9.9 version from the app4mc download site, you should only be able to create 0.9.9 versions of the model.

Or, because you said "existing model", is this model somehow taken from a very very old version 1.0.0 of the AMALTHEA-ITEA project? They had there once a 1.0.0 AMALTHEA version around 2014, but when they transfered to Eclipse Foundation, they renumbered APP4MC. If this is true, then I wonder, if there is actually a converter available at all for such an old file.
Previous Topic:HW MemoryDefinition, Memory and MemoryMapping
Next Topic: NO APP4MC Multicore Support Feature
Goto Forum:
  


Current Time: Sat May 21 15:47:17 GMT 2022

Powered by FUDForum. Page generated in 0.02178 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top