Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » Oomph Customization
Oomph Customization [message #1833327] Fri, 09 October 2020 10:09 Go to next message
Gopi Krishna Gobbilla is currently offline Gopi Krishna GobbillaFriend
Messages: 7
Registered: February 2016
Junior Member
Hi,
I have made some changes in the Oomph source code to customize git checkout for workspace setup of installed eclipse product.
I have built an update site from the feature org.eclipse.oomph.setup
and changed the eclipse-inst.ini to have below, so that feature org.eclipse.oomph.setup is installed from my custom update site
-Doomph.update.url=file:///C:/temp/org.eclipse.oomph.setup.update.site

But the installation fails, please check the below image.
Could you please help ? Thank you.
The complete error log is also attached error.log


index.php/fa/39041/0/
  • Attachment: InstallError.png
    (Size: 126.66KB, Downloaded 159 times)
  • Attachment: error.log
    (Size: 31.83KB, Downloaded 24 times)

[Updated on: Fri, 09 October 2020 10:10]

Report message to a moderator

Re: Oomph Customization [message #1833328 is a reply to message #1833327] Fri, 09 October 2020 10:19 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32110
Registered: July 2009
Senior Member
I'm not sure why there are two separate p2 director tasks rather than one merged one. Did you set "Merged Disabled" on the p2 director task? The Oomph repository doesn't contain all the dependencies...

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Oomph Customization [message #1833331 is a reply to message #1833328] Fri, 09 October 2020 10:34 Go to previous messageGo to next message
Gopi Krishna Gobbilla is currently offline Gopi Krishna GobbillaFriend
Messages: 7
Registered: February 2016
Junior Member
Hi,
Yes, I have set Merge Disabled to true for the P2 task of org.eclipse.oomph.setup, otherwise this is not installed from my own update site, but instead installing from
http://download.eclipse.org/releases/2020-06/202006171000

The required dependency org.eclipse.core.runtime is available in the first P2 Director task Eclipse Platform (2020-09), and this is installed before.

So then why this dependency could not be resolved ?
or
How can I install org.eclipse.oomph.setup from my own update site with Merge Disabled to false ?

[Updated on: Mon, 12 October 2020 10:44]

Report message to a moderator

Re: Oomph Customization [message #1833347 is a reply to message #1833331] Fri, 09 October 2020 15:12 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 32110
Registered: July 2009
Senior Member
I would expect the p2 version to install the stuff with the newest version. I very commonly do a local build to produce a p2 repository and run the installer with the repository, installing what I just build along with whatever is in the release train repository.

In any case, each separate p2 task must be able to resolve all the requirements so this approach is not a good way. Do your customized plugins not have higher version numbers than the one in the train repository?


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Update issue with product containing fragments
Next Topic:Stop Eclipse Installer from tampering with Eclipse JRE
Goto Forum:
  


Current Time: Fri Dec 03 17:46:35 GMT 2021

Powered by FUDForum. Page generated in 0.02182 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top