Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse 2020-09 crashes repeatedly, errors with multiple plugins (Eclipse 2020-09 crashes / unstability)
Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832718] Wed, 23 September 2020 20:16 Go to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
My eclipse upgraded itself to 2020-09 yesterday. I'm really shocked it was released with this much instability in it. If there is so many problems (unexpected crashes, plugin errors, etc), why did it get forced to be released today!

Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832719 is a reply to message #1832718] Wed, 23 September 2020 20:21 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
Is there any easy way to rollback a 2020-09 continuous build upgrade to revert back to 2020-06?
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832720 is a reply to message #1832719] Wed, 23 September 2020 20:22 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
I can see all the Scala-IDE content assists are failing in the auto-complete logic again :(
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832722 is a reply to message #1832720] Wed, 23 September 2020 20:29 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
index.php/fa/38972/0/The Java postfix Template is also failing in the content assist as well as is the TemplateProposalComputer! index.php/fa/38973/0/

[Updated on: Wed, 23 September 2020 20:31]

Report message to a moderator

Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832724 is a reply to message #1832722] Wed, 23 September 2020 20:47 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
Errors occurred during the build.
Errors running builder 'Scala Builder' on project 'resolverservice'.
Unable to find Asm for stackmap generation (Looking for 'aj.org.objectweb.asm.ClassReader'). Stackmap generation for woven code is required to avoid verify errors on a Java 1.7 or higher runtime
when weaving type org.eclipse.jdt.internal.compiler.lookup.MethodVerifier
when weaving classes
when weaving
when weaving classes
when weaving
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832725 is a reply to message #1832719] Wed, 23 September 2020 20:55 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3954
Registered: July 2009
Senior Member

There's not generally a continuous update the way that something like Chrome operates,
but you can try opening the About dialog, going into the Installation Details, and seeing
what you can do from the Update History.

Was there a reason you wrote 5 posts in the same thread replying to yourself? Posts are editable.


Nitin Dahyabhai
Eclipse Web Tools Platform

[Updated on: Wed, 23 September 2020 20:56]

Report message to a moderator

Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832728 is a reply to message #1832724] Wed, 23 September 2020 22:04 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
index.php/fa/38974/0/I've tried creating a new workspace -> doesn't work

I've tried downloading / installing a new Eclipse 2020-09 from scratch -> fewer errors but nothing compiles. Also I can only open scala classes using a text editor. (Both compiling and file opening) fail on the "required to avoid verify errors on a Java 1.7 or higher runtime when weaving type org.eclipse.jdt.core.search.SearchDocument when weaving classes when weaving" error :(

@DahyabhaiFriend, I stumbled into this when my eclipse 2020-06 auto updated to 2020-09. (I originally installed this as a 2018 install).

That said, installing 2020-09 on my Mac from a fresh download and a fresh workspace is not resolving all the issues and I'm still facing basic "IDE does not compile issues".

btw, I've been using Eclipse going back to 2001.

[Updated on: Wed, 23 September 2020 23:04]

Report message to a moderator

Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832729 is a reply to message #1832728] Wed, 23 September 2020 22:09 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
index.php/fa/38976/0/index.php/fa/38975/0/when I try to navigate to the eclipse/preferences/installed JREs settings I get another failure and the screen doesn't render

Errors running builder 'Scala Builder' on project 'sfsync-resolve'.
Unable to find Asm for stackmap generation (Looking for 'aj.org.objectweb.asm.ClassReader'). Stackmap generation for woven code is required to avoid verify errors on a Java 1.7 or higher runtime

[Updated on: Wed, 23 September 2020 23:12]

Report message to a moderator

Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832730 is a reply to message #1832729] Wed, 23 September 2020 23:36 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3954
Registered: July 2009
Senior Member

You seem to have some tools installed for Scala and...I'm guessing AspectJ? You'd want to open bug reports for those.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832736 is a reply to message #1832730] Thu, 24 September 2020 04:58 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31702
Registered: July 2009
Senior Member
My suspicion is that the Scala IDE plugs were never tested to work with Java 11 and now Eclipse itself requires Java 11. Or perhaps you have an older version of Scala IDE that doesn't work with Java 11 and there is a newer one that does work. But the one I just downloaded from here:

http://scala-ide.org/download/sdk.html

brings up an Oxygen version of Eclipse and that version definitely doesn't run with Java 11; it won't even start with Java 11. Their latest release appears to be 2.5 years old so it's not so surprising that it doesn't work with the latest version if Eclipse...


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832772 is a reply to message #1832736] Thu, 24 September 2020 16:38 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
I seems like the scala systems have issues. Java seems broken too (see my above screenshot of the "installed JREs preferences panel not loading").

FWIW, scala has declared they aren't working on the eclipse IDE again until they have Scala 3 out. Scala 3 won't be released until after Scala 2.14 comes out.

https://www.scala-lang.org/blog/2018/04/19/scala-3.html

well, guess I'm moving back to Oxygen forever. :(

#eclipseBrokeCompatibilityToAnEntireProgrammingLanguage

[Updated on: Thu, 24 September 2020 16:44]

Report message to a moderator

Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832773 is a reply to message #1832772] Thu, 24 September 2020 16:58 Go to previous messageGo to next message
Andrew Norman is currently offline Andrew NormanFriend
Messages: 20
Registered: May 2017
Junior Member
Java 1.8 is an "LTS" version that oracle is supporting until 2030 so I'm a bit surprised that Eclipse doesn't also support it long term

https://en.wikipedia.org/wiki/Java_version_history
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1832779 is a reply to message #1832773] Thu, 24 September 2020 21:11 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3954
Registered: July 2009
Senior Member

You can develop your projects against Java 1.8 just fine in 2020-09. Eclipse itself needs Java 11.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse 2020-09 crashes repeatedly, errors with multiple plugins [message #1833693 is a reply to message #1832718] Wed, 21 October 2020 16:33 Go to previous message
Nathan Niesen is currently offline Nathan NiesenFriend
Messages: 1
Registered: October 2020
Junior Member
I updated my JDK from OpenJDK 11.0.4.11 to 11.0.8.10 seems to have resolved the problems for me. I use the eclipse zip install method.

Thanks to this post indicating that the using the installer with the bundled JDK worked:
stackoverflow.com/questions/64319086/eclipse-unable-to-find-asm

#EDIT 2020-10-28
I continued to get similar errors for other parts. I ended up using the installer to get the "bundled" jdk. That worked great for a few days and then I was back to getting ASM and weaving errors for various things including searches. I tried installing the "Eclipse Automated Error Reporting" feature to reporting these hard to reproduce errors but then I could no longer open JDK classes like DateTimeFormmatter even after reverting the install. For now, my only recourse seems to be going back my 2020-06 install and workspace. :(

[Updated on: Wed, 28 October 2020 19:51]

Report message to a moderator

Previous Topic:hello all, i am new to this forum
Next Topic:Eclipse Ecore Repository
Goto Forum:
  


Current Time: Mon Jan 18 05:30:11 GMT 2021

Powered by FUDForum. Page generated in 0.04123 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top