Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » Updating ecore resource slows down build process
Updating ecore resource slows down build process [message #1832450] Fri, 18 September 2020 08:37 Go to next message
Gunnar Arndt is currently offline Gunnar ArndtFriend
Messages: 73
Registered: June 2012
Member
During each build process in Eclipse 4.16, the progress view stalls for minutes with the message 'Building myProject: Updating resource myModel.ecore', which sums up during an office day. That file is about 188kB large.
Is there anything I can do to accelerate the build process, e.g. preven that resource update unless it actually changed? (Is this the right forum?)
Thank you in advance.
Re: Updating ecore resource slows down build process [message #1832457 is a reply to message #1832450] Fri, 18 September 2020 10:20 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31826
Registered: July 2009
Senior Member
Does this project have an Xtext nature? I.e., this in the .project file:
<nature>org.eclipse.xtext.ui.shared.xtextNature</nature>
You can make .* files visible via the view menu's Filters... and uncheck the .* resources item.

Nothing in EMF itself does such building...


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Updating ecore resource slows down build process [message #1832459 is a reply to message #1832457] Fri, 18 September 2020 11:13 Go to previous messageGo to next message
Gunnar Arndt is currently offline Gunnar ArndtFriend
Messages: 73
Registered: June 2012
Member
Ed, thanks for the hint. Yes, it has Xtext nature, because we use an Xtext based DSL as a boiler plate code generator in the project. I'm checking what happens when it is disabled. Maybe I'll just have to move the Ecore file to a separate project without Xtext.
Re: Updating ecore resource slows down build process [message #1832463 is a reply to message #1832459] Fri, 18 September 2020 12:06 Go to previous messageGo to next message
Gunnar Arndt is currently offline Gunnar ArndtFriend
Messages: 73
Registered: June 2012
Member
That is a helpful workaround indeed: Keep Ecore files and 'actual' Xtext stuff in separate projects. Ecore code generation to the same project is no problem via the genmodel's settings.

[Updated on: Fri, 18 September 2020 12:07]

Report message to a moderator

Re: Updating ecore resource slows down build process [message #1832477 is a reply to message #1832463] Fri, 18 September 2020 14:00 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7091
Registered: July 2009
Senior Member
Hi

See https://www.eclipse.org/forums/index.php?t=msg&th=1105235&goto=1832475&#msg_1832475 on the Xtext forum for clearer guidance. The *.ecore can live with its built editor and NO Xtext nature, it is only the developer's build stuff that needs to be kept separate with an Xtext nature.

Regards

Ed Willink
Previous Topic:Downsides to bi-directional references?
Next Topic:Xcore editor not loaded anymore
Goto Forum:
  


Current Time: Sun Apr 11 15:55:48 GMT 2021

Powered by FUDForum. Page generated in 0.02011 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top