Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Update Site for an Eclipse plugin project(Need help creating an update site for an Eclipse plugin project)
Update Site for an Eclipse plugin project [message #1831630] Tue, 25 August 2020 16:32 Go to next message
Jannis Brune is currently offline Jannis BruneFriend
Messages: 2
Registered: August 2020
Junior Member
I am trying to automate an existing Eclipse plugin project with Tycho Maven.
Before I convert the actual project, I tried a demo project. After some failures it finally worked out. But I have problems getting the update site to work.

I can create the update site manualy (via Export -> Deployable Feature), but my UpdateSite-Project is throwing errors some weird errors:

I have specified the tycho-maven-plugin in the pom.xml from the parent project. There the version 1.7.0 was defined.

But supposedly version 0.22.0 was defined in the pom.xml of the updateSite. But this never happened.

[INFO] Scanning for projects...
[ERROR] Several versions of tycho plugins are configured [0.22.0, 1.7.0]:
[ERROR] 0.22.0:
[ERROR] 	MavenProject: com.vogella.ide.updatesite:com.vogella.ide.updatesite:1.0.0 @ C:\[...]\workspaces\yamm-maven-migration\com.vogella.ide.updatesite\pom.xml
[ERROR] 1.7.0:
[ERROR] 	MavenProject: com.vogella.ide.parent:com.vogella.ide.parent:1.0.0 @ C:\[...]\workspaces\yamm-maven-migration\com.vogella.ide.parent\pom.xml
[ERROR] All tycho plugins configured in one reactor must use the same version -> [Help 1]
[...]


If I specify version 0.22.0 in the parent project, the error does not appear anymore.

You can find the two pom files in the attachment. What could be the reason for this?

My second problem occurs when I use version 0.22.0 of tycho-maven:


[INFO] Resolving dependencies of MavenProject: com.vogella.ide.updatesite:com.vogella.ide.updatesite:1.0.0 @ C:\[...]\workspaces\yamm-maven-migration\com.vogella.ide.updatesite\pom.xml
[INFO] {osgi.os=win32, osgi.ws=win32, org.eclipse.update.install.features=true, osgi.arch=x86_64}
[ERROR] Cannot resolve project dependencies:
[ERROR]   Software being installed: com.vogella.ide.updatesite 1.0.0
[ERROR]   Missing requirement: com.vogella.ide.updatesite 1.0.0 requires 'com.vogella.ide.feature.feature.group [1.0.0,1.0.1)' but it could not be found
[...]


Why can't he find my feature even though the project was created for it?

Without the "com.vogella.ide.updatesite" module, maven can successfully build the project.

index.php/fa/38818/0/

Thanks in advance
Jannis
Re: Update Site for an Eclipse plugin project [message #1831644 is a reply to message #1831630] Wed, 26 August 2020 06:27 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31476
Registered: July 2009
Senior Member
If you have problems with a specific sample, you should probably ask about at where you got that sample from.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Update Site for an Eclipse plugin project [message #1831647 is a reply to message #1831644] Wed, 26 August 2020 07:10 Go to previous messageGo to next message
Jannis Brune is currently offline Jannis BruneFriend
Messages: 2
Registered: August 2020
Junior Member
The tutorial only refers to the creation of an Eclipse plugin. Automation using Tycho Maven was not part of the tutorial.
For this I have oriented myself on the wizard for Xtext projects. Probably not the best approach, but the number of up-to-date tutorials is very limited.
Re: Update Site for an Eclipse plugin project [message #1831652 is a reply to message #1831647] Wed, 26 August 2020 07:36 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31476
Registered: July 2009
Senior Member
I see. Tycho 2.0.0 just released so certainly I would try to get it all working with either Tycho 1.7.0 or with 2.0.0. The 0.22.0 is really old and it might well be buggy.

If you have Tycho-specific questions, those are best posted to their user mailing list:

https://accounts.eclipse.org/mailing-list/tycho-user

The JustJ tools repository has a relatively simple working example for producing and update site, so you might have a look at that:

https://www.eclipse.org/justj/?page=developer

The overall setup is a little more complex but is automated:

https://www.eclipse.org/setups/installer/?url=https://git.eclipse.org/c/justj/justj.tools.git/plain/releng/org.eclipse.justj.tools.releng/JustJConfiguration.setup&show=true

It's only the tools part that simple, not all the stuff for building JRE...


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Error installing
Next Topic:Editor windows relocating themselves
Goto Forum:
  


Current Time: Wed Sep 23 19:59:00 GMT 2020

Powered by FUDForum. Page generated in 0.02542 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top