Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Problem installing eclipse(java.io.IOException: Failed to create directory)
Problem installing eclipse [message #1830688] Fri, 31 July 2020 10:43 Go to next message
Toni Kühnl is currently offline Toni KühnlFriend
Messages: 1
Registered: July 2020
Junior Member
Every time I try to istal eclipse I get the following error:

ERROR: org.eclipse.equinox.p2.artifact.repository code=1003 Unable to write to repository: file:/C:/Users/tonid/.p2/pool.
java.io.IOException: Failed to create directory C:\Users\tonid\.p2\pool\plugins.

The problem I see is that my user folder is not named "tonid" it is named" toni" I changed that a while back because it was bothering me.

I reinstalled the jdk multiple times als well as deleted the eclipse installer.

How do get the java.io.IOException to created a directory at "C:\Users\toni\.p2\pool\plugins." because I think that would fix the problem?

If anyone could help me with that it would be very kind.
Re: Problem installing eclipse [message #1830693 is a reply to message #1830688] Fri, 31 July 2020 15:09 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31342
Registered: July 2009
Senior Member
If you open a cmd command prompt and run "set" are any of the environment variables pointing at C:\Users\tonid rather than C:\Users\toni? I think HOMEPATH/HOMEDRIVE is the most important one because I think that's used to determine the value of the user.home system property.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Problem installing eclipse [message #1830694 is a reply to message #1830693] Fri, 31 July 2020 15:19 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31342
Registered: July 2009
Senior Member
Also, if you've previous installed Eclipse before renaming the folder/account name, there are likely things in <home>/.eclipse/... and <home>/.p2/... that have references to the older value of <home>. That will cause problems as well. Easiest would be two delete these two folders if that's the case.

Don't bother trying to reinstall the JDK, that should not be a problem...


Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:Problems with in-house plugins when using latest Eclipse CDT (2020-06)
Next Topic:Changing preferences for certain windows in Eclipse
Goto Forum:
  


Current Time: Tue Aug 04 01:36:44 GMT 2020

Powered by FUDForum. Page generated in 0.02519 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top