Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Standard Widget Toolkit (SWT) » GLib-CRITICAL
GLib-CRITICAL [message #1830616] Wed, 29 July 2020 21:02 Go to next message
Esteban Avila is currently offline Esteban AvilaFriend
Messages: 49
Registered: June 2012
Member
Hello everyone, i have a rcp application that run on windows and linux.
First off all, in windows all is working fine, but when i compile the app on linux i have a lot of this message outputs.

GLib-CRITICAL **: 09:40:58.143: g_base64_encode_step: assertion 'in != NULL' failed
Gtk-WARNING **: 09:41:00.169: Negative content height -7 (allocation 1, extents 4x4) while allocating gadget (node button, owner GtkToggleButton)

the linux version is:
Linux 3.10.0-957.10.1.el7.x86_64 GNU/Linux

For the other hand i have problems with the visualization of the controls, maybe is releated with the other issue.

I try to change the --launcher.GTK_version 2 in the .ini file but the controls problems remains.

Someone can help me with this, i am in a dead road
Thanks

Re: GLib-CRITICAL [message #1830988 is a reply to message #1830616] Sat, 08 August 2020 03:26 Go to previous message
Andy Maleh is currently offline Andy MalehFriend
Messages: 22
Registered: March 2020
Junior Member
They recently raised the minimum GTK version supported by SWT as mentioned here:
https://www.eclipse.org/eclipse/news/4.16/platform_isv.html

"Starting from Eclipse 4.16, SWT/GTK no longer supports versions of GTK older than 3.20."


OSS Author of Glimmer (GUI DSL for SWT)
https://github.com/AndyObtiva/glimmer
Previous Topic:Custom Dialog to open files and folders
Next Topic:HiDPI dynamical scaling does not adapt window content in Java 11
Goto Forum:
  


Current Time: Wed Apr 21 15:25:14 GMT 2021

Powered by FUDForum. Page generated in 0.01614 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top