Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse 2020-06 failed to start after update(Log shows NullPointerException at ResourceHandler.getResource)
Eclipse 2020-06 failed to start after update [message #1830085] Fri, 17 July 2020 06:46 Go to next message
Olga Vashchenko is currently offline Olga VashchenkoFriend
Messages: 4
Registered: July 2020
Junior Member
Hello.
After yesterday's careless update my Eclipse fails to start.

The main exception (i think it causes the failure) is here:

!ENTRY org.eclipse.e4.ui.workbench 4 0 2020-07-17 09:04:01.277
!MESSAGE Unable to load resource file:/C:/Users/Vashchanka_V/eclipse-workspace/.metadata/.plugins/org.eclipse.e4.workbench/workbench.xmi
!STACK 0
java.lang.NullPointerException
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.getResource(ResourceHandler.java:287)
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadResource(ResourceHandler.java:263)
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMostRecentModel(ResourceHandler.java:169)
...................

Please help me with this :) Can't work without it..
Re: Eclipse 2020-06 failed to start after update [message #1830112 is a reply to message #1830085] Fri, 17 July 2020 13:07 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3783
Registered: July 2009
Senior Member

Are there other exceptions?

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Eclipse 2020-06 failed to start after update [message #1830120 is a reply to message #1830112] Fri, 17 July 2020 14:55 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31342
Registered: July 2009
Senior Member
You could try running eclipse.exe -clearPersistedState so that it doesn't load the workbench.xmi but rather creates a new one. Only the layout of windows, open perspectives and open editors will be clear, not the contents of the workspace.

Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse 2020-06 failed to start after update [message #1830121 is a reply to message #1830112] Fri, 17 July 2020 15:17 Go to previous messageGo to next message
Olga Vashchenko is currently offline Olga VashchenkoFriend
Messages: 4
Registered: July 2020
Junior Member
Other exceptions (following the above one):
!MESSAGE The persisted application model has no top-level window. Reinitializing with the default application model.
!STACK 0
java.lang.Exception
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMostRecentModel(ResourceHandler.java:174)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.loadApplicationModel(E4Application.java:384)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:260)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:579)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:557)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:150)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1447)

!ENTRY org.eclipse.e4.ui.workbench 4 0 2020-07-17 12:14:45.903
!MESSAGE Unable to load resource platform:/plugin/org.eclipse.platform/LegacyIDE.e4xmi
!STACK 0
java.lang.NullPointerException
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.getResource(ResourceHandler.java:287)
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadResource(ResourceHandler.java:263)
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMostRecentModel(ResourceHandler.java:181)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.loadApplicationModel(E4Application.java:384)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:260)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:579)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:557)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:150)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1447)

!ENTRY org.eclipse.osgi 4 0 2020-07-17 12:14:45.955
!MESSAGE Application error
!STACK 1
java.lang.NullPointerException
at org.eclipse.e4.ui.internal.workbench.ResourceHandler.loadMostRecentModel(ResourceHandler.java:182)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.loadApplicationModel(E4Application.java:384)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:260)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:579)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:557)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:154)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:150)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1447)
Re: Eclipse 2020-06 failed to start after update [message #1830124 is a reply to message #1830120] Fri, 17 July 2020 15:23 Go to previous messageGo to next message
Olga Vashchenko is currently offline Olga VashchenkoFriend
Messages: 4
Registered: July 2020
Junior Member
Ed Merks wrote on Fri, 17 July 2020 14:55
You could try running eclipse.exe -clearPersistedState so that it doesn't load the workbench.xmi but rather creates a new one. Only the layout of windows, open perspectives and open editors will be clear, not the contents of the workspace.



Didn't help :(
Failed with 2 last exceptions from my previous answer to Nitin Dahyabhai (with LegacyIDE).
Re: Eclipse 2020-06 failed to start after update [message #1830149 is a reply to message #1830124] Sat, 18 July 2020 05:05 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31342
Registered: July 2009
Senior Member
If you open with a brand new clean workspace rather than an existing one, do you have the same exceptions? You might also try running with -clean. If you delete the <workspace>/.metadata/.log before you launch, a new .log will be created when new problems are logged. If you could attach that, we'd be sure there are not other logged issues that cause the logged issue you've copied and pasted. (I think you need to do Preview Quick Reply before you can attach the .log).


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse 2020-06 failed to start after update [message #1830182 is a reply to message #1830149] Mon, 20 July 2020 06:47 Go to previous message
Olga Vashchenko is currently offline Olga VashchenkoFriend
Messages: 4
Registered: July 2020
Junior Member
Ed Merks wrote on Sat, 18 July 2020 05:05
If you open with a brand new clean workspace rather than an existing one, do you have the same exceptions? You might also try running with -clean. If you delete the <workspace>/.metadata/.log before you launch, a new .log will be created when new problems are logged. If you could attach that, we'd be sure there are not other logged issues that cause the logged issue you've copied and pasted. (I think you need to do Preview Quick Reply before you can attach the .log).


Thank you, Ed!!! The -clean command fixed the problem :)
For possible future readers: simple deleting of all the files from the workspace is not enough.
Previous Topic:Eclipse won't run on Windows 10
Next Topic:Eclipse WindowBuilder with PDE
Goto Forum:
  


Current Time: Tue Aug 04 00:41:24 GMT 2020

Powered by FUDForum. Page generated in 0.02836 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top