Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Eclipse IDE for RCP (2020-06) hangs opening build.xml files
Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829488] Sat, 04 July 2020 23:55 Go to next message
Hernán González is currently offline Hernán GonzálezFriend
Messages: 4
Registered: July 2020
Junior Member
I've been using Eclipse IDE for RCP since 2008. Latest version exhibits many freezing problems. I've experienced frequent and fatal IDE freezes when opening ANT buildfiles.

The following steps don't reproduce the total freeze I experience in my development environment, but anyway a lag is noticeable, and they trigger "UI freeze" warnings and other ugly message in the logs - and this, mind you, starting from a total clean installation.

My environment : Windows-7, Java 1.8.0_231, 64 bits.

I download eclipse-rcp-2020-06-R-win32-x86_64.zip , unpack, and run in with a new workspace (previously I removed %USERPROFILE%/.eclipse, just in case)

I create a new empty Java project, from the wizard. I generate a build.xml file (via "Export -> Ant buildfile"). (again, just in case, I close Eclipse, remove any .log file in workspace, and open it again).
I click to open build.xml
A noticeable lag occurs. Finally the Ant editor opens.

Logs in WORSKPACE/metadata/.log show "MESSAGE UI freeze" with different warnings in different run.

I attach several examples


  • Attachment: .log1
    (Size: 35.67KB, Downloaded 62 times)
  • Attachment: .log2
    (Size: 40.66KB, Downloaded 55 times)
  • Attachment: .log3
    (Size: 13.62KB, Downloaded 53 times)
  • Attachment: .log4
    (Size: 25.33KB, Downloaded 56 times)
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829493 is a reply to message #1829488] Sun, 05 July 2020 10:34 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 235
Registered: April 2012
Senior Member
First thing that comes to mind is that this might be related to Windows Defender. For details see https://eclip.se/548443

Basically when you are using Windows Defender it can delay any Java process. Can you confirm / exclude the influence of that virus scanner, looking at the Windows Task manager should give you a good clue.
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829499 is a reply to message #1829488] Sun, 05 July 2020 15:09 Go to previous messageGo to next message
Hernán González is currently offline Hernán GonzálezFriend
Messages: 4
Registered: July 2020
Junior Member
Hi Rolf. Thanks for answering.

This is not related with Defender or antivirus.
For one thing, the problem is still when I disable my antivirus (not Defender but Essentials).
Second: I've using Eclipse-RCP more than 10 years, this problem started when I migrated to 2020-06 from 2019-09 (4.13.0).

Also: my problem is much worse than that reproduced on those steps. In my real scenario, Eclipse freezes completely ("Not responding"), always (I've waited several minutes, and I always have to kill the process) when I open my own Ant build file. The messages in the logs are similar, I attached the real log for my total freeze scenario (no more logs are emmited afterwards)

  • Attachment: log6.txt
    (Size: 30.77KB, Downloaded 53 times)
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829514 is a reply to message #1829499] Mon, 06 July 2020 04:59 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 32075
Registered: July 2009
Senior Member
From the log, I can't tell what the main thread is doing. I would suggest reporting a deadlock:

https://wiki.eclipse.org/How_to_report_a_deadlock#Using_jvisualvm

The stack traces in the log suggests that the ant classpath depends on the selected resource in the UI, which seems weird...


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829523 is a reply to message #1829514] Mon, 06 July 2020 07:08 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 235
Registered: April 2012
Senior Member
It seems that org.eclipse.ant.internal.ui.editor.text.NotifyingReconciler tries to get synchronously back to the UI main thread. If that thread is waiting for the job that triggers the NotifyingReconciler, there is a deadlock. As Ed mentioned, full stack traces are need to analyze this problem and please open a bug report.

Might be related or have the same cause as this bug too: https://eclip.se/308502
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829630 is a reply to message #1829523] Wed, 08 July 2020 03:57 Go to previous messageGo to next message
Hernán González is currently offline Hernán GonzálezFriend
Messages: 4
Registered: July 2020
Junior Member
Done https://www.eclipse.org/forums/index.php?t=rview&goto=1829523
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829637 is a reply to message #1829630] Wed, 08 July 2020 06:28 Go to previous messageGo to next message
Rolf Theunissen is currently offline Rolf TheunissenFriend
Messages: 235
Registered: April 2012
Senior Member
I think you mean https://bugs.eclipse.org/bugs/show_bug.cgi?id=565033
Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1829786 is a reply to message #1829637] Fri, 10 July 2020 14:43 Go to previous messageGo to next message
Hernán González is currently offline Hernán GonzálezFriend
Messages: 4
Registered: July 2020
Junior Member
Yes, sorry

I've also add a reproducible case (for me at least) of my complete deadlock scenario, with a fresh version of Eclipse RCP and with Windows 10.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=565033#c2

[Updated on: Fri, 10 July 2020 14:45]

Report message to a moderator

Re: Eclipse IDE for RCP (2020-06) hangs opening build.xml files [message #1831739 is a reply to message #1829786] Thu, 27 August 2020 19:49 Go to previous message
Lincoln Alves is currently offline Lincoln AlvesFriend
Messages: 2
Registered: August 2020
Junior Member
Hey Hernán!

I was also experiencing some problems after updating to Eclipse 2020-06. It was slow and with some Maven errors. Today, it started to freeze before the Workspace selection.

After some research, I decided to update my computer's JRE to Java 11. Not only it started working again, but it got really faster performancewise. Even Maven errors stopped happening.

If possible, give it a try! Best regards!
Previous Topic:How to Filter Problems View Programmatically
Next Topic:Missing Junit Plugin in Container
Goto Forum:
  


Current Time: Sat Oct 23 09:16:42 GMT 2021

Powered by FUDForum. Page generated in 0.02002 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top