Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Gemini » gemini web Failed to start component ( gemini web Failed to start component )
gemini web Failed to start component [message #1829442] Fri, 03 July 2020 15:19 Go to next message
Martin Zukal is currently offline Martin ZukalFriend
Messages: 5
Registered: February 2019
Junior Member
Hi everyone,
we are using gemini.web in virgo application server to run an osgi-based application with UI based on primefaces. The version of gemini.web is 3.0.5.RELEASE the org.apache.tomcat/org.apache.catalina bundles are in version 8.5.53. When I tried to upgrade JSF version from 2.2 to 2.3 I ran into the following error during start up:

[2020-07-03 16:31:31.150] ERROR start-signalling-2 org.apache.catalina.core.ContainerBase ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].ExtendedStandardContext[/main]]
at org.apache.catalina.util.LifecycleBase.handleSubClassException(LifecycleBase.java:440)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:198)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:743)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)
at org.eclipse.gemini.web.tomcat.internal.TomcatServletContainer.startWebApplication(TomcatServletContainer.java:125)
at org.eclipse.gemini.web.internal.StandardWebApplication.start(StandardWebApplication.java:109)
at org.eclipse.virgo.web.core.internal.WebBundleLifecycleListener.onStarted(WebBundleLifecycleListener.java:122)
at org.eclipse.virgo.kernel.install.artifact.internal.StandardArtifactStateMonitor.onStarted(StandardArtifactStateMonitor.java:271)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.asyncStartSucceeded(AbstractInstallArtifact.java:319)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.access$0(AbstractInstallArtifact.java:316)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact$StateMonitorSignal.signalSuccessfulCompletion(AbstractInstallArtifact.java:252)
at org.eclipse.virgo.nano.core.internal.BundleStartTracker$1.run(BundleStartTracker.java:140)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.IllegalArgumentException: The URL protocol [file] is not supported by this web resources implementation
at org.eclipse.gemini.web.tomcat.internal.bundleresources.BundleWebResourceRoot$BaseLocation.<init>(BundleWebResourceRoot.java:150)
at org.eclipse.gemini.web.tomcat.internal.bundleresources.BundleWebResourceRoot.createWebResourceSet(BundleWebResourceRoot.java:50)
at org.apache.catalina.startup.ContextConfig.processResourceJARs(ContextConfig.java:1703)
at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1189)
at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:776)
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:299)
at org.apache.catalina.util.LifecycleBase.fireLifecycleEvent(LifecycleBase.java:123)
at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5065)
at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:183)
... 14 common frames omitted

[2020-07-03 16:31:31.167] ERROR start-signalling-2 org.eclipse.gemini.web.internal.StandardWebApplication Failed to start web application at context path '/main' org.eclipse.gemini.web.core.spi.ServletContainerException: Web application at [/main] cannot be added to the host.
at org.eclipse.gemini.web.tomcat.internal.TomcatServletContainer.startWebApplication(TomcatServletContainer.java:128)
at org.eclipse.gemini.web.internal.StandardWebApplication.start(StandardWebApplication.java:109)
at org.eclipse.virgo.web.core.internal.WebBundleLifecycleListener.onStarted(WebBundleLifecycleListener.java:122)
at org.eclipse.virgo.kernel.install.artifact.internal.StandardArtifactStateMonitor.onStarted(StandardArtifactStateMonitor.java:271)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.asyncStartSucceeded(AbstractInstallArtifact.java:319)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.access$0(AbstractInstallArtifact.java:316)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact$StateMonitorSignal.signalSuccessfulCompletion(AbstractInstallArtifact.java:252)
at org.eclipse.virgo.nano.core.internal.BundleStartTracker$1.run(BundleStartTracker.java:140)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].ExtendedStandardContext[/main]]
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:747)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:719)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:705)
at org.eclipse.gemini.web.tomcat.internal.TomcatServletContainer.startWebApplication(TomcatServletContainer.java:125)
... 10 common frames omitted

[2020-07-03 16:31:31.175] ERROR start-signalling-2 org.eclipse.virgo.medic.eventlog.default WE0005E Failed to start web bundle 'com.example.core.ui' version '9.0.0.SNAPSHOT': consult serviceability/logs/log.log for further details.
[2020-07-03 16:31:31.175] INFO start-signalling-2 o.e.v.k.i.artifact.internal.bundle.BundleThreadContextManager Thread context class loader 'KernelBundleClassLoader: [bundle=com.example.core.ui_9.0.0.SNAPSHOT]' popped and set to 'KernelBundleClassLoader: [bundle=org.apache.commons.pool_1.6.0]'
[2020-07-03 16:31:31.176] INFO start-signalling-2 o.e.v.k.i.artifact.internal.bundle.BundleThreadContextManager Thread context class loader 'KernelBundleClassLoader: [bundle=org.apache.commons.pool_1.6.0]' pushed and set to 'KernelBundleClassLoader: [bundle=com.example.core.ui_9.0.0.SNAPSHOT]'
[2020-07-03 16:31:31.241] ERROR start-signalling-2 org.eclipse.virgo.medic.eventlog.default DE0006E Start failed for bundle 'com.example.core.ui' version '9.0.0.SNAPSHOT'. org.eclipse.virgo.nano.deployer.api.core.DeploymentException: Web application failed to start
at org.eclipse.virgo.web.core.internal.WebBundleLifecycleListener.onStarted(WebBundleLifecycleListener.java:132)
at org.eclipse.virgo.kernel.install.artifact.internal.StandardArtifactStateMonitor.onStarted(StandardArtifactStateMonitor.java:271)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.asyncStartSucceeded(AbstractInstallArtifact.java:319)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact.access$0(AbstractInstallArtifact.java:316)
at org.eclipse.virgo.kernel.install.artifact.internal.AbstractInstallArtifact$StateMonitorSignal.signalSuccessfulCompletion(AbstractInstallArtifact.java:252)
at org.eclipse.virgo.nano.core.internal.BundleStartTracker$1.run(BundleStartTracker.java:140)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:748)
Caused by: org.eclipse.gemini.web.core.WebApplicationStartFailedException: org.eclipse.gemini.web.core.spi.ServletContainerException: Web application at [/main] cannot be added to the host.
at org.eclipse.gemini.web.internal.StandardWebApplication.start(StandardWebApplication.java:137)
at org.eclipse.virgo.web.core.internal.WebBundleLifecycleListener.onStarted(WebBundleLifecycleListener.java:122)
... 8 common frames omitted
Caused by: org.eclipse.gemini.web.core.spi.ServletContainerException: Web application at [/main] cannot be added to the host.
at org.eclipse.gemini.web.tomcat.internal.TomcatServletContainer.startWebApplication(TomcatServletContainer.java:128)
at org.eclipse.gemini.web.internal.StandardWebApplication.start(StandardWebApplication.java:109)

Unfortunately the log files does not contain more information related to the above described problem except for the the following warn messages:
[2020-07-03 16:55:20.887] INFO start-signalling-2 org.apache.catalina.core.StandardContext Unable to set the web application class loader property [clearReferencesObjectStreamClassCaches] to [true] as the property does not exist.
[2020-07-03 16:55:20.887] INFO start-signalling-2 org.apache.catalina.core.StandardContext Unable to set the web application class loader property [clearReferencesThreadLocals] to [true] as the property does not exist.

Which I am not sure if can be related or not.

When I try to start the application without that bundle the application starts fine.

Any help to track down and solve the problem is highly appreciated.


Martin Zukal
Re: gemini web Failed to start component [message #1829444 is a reply to message #1829442] Fri, 03 July 2020 15:36 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 278
Registered: October 2010
Senior Member
Can you try Gemini Web 3.0.6?
https://bugs.eclipse.org/bugs/show_bug.cgi?id=563105#c15
Re: gemini web Failed to start component [message #1830192 is a reply to message #1829444] Mon, 20 July 2020 09:55 Go to previous messageGo to next message
Martin Zukal is currently offline Martin ZukalFriend
Messages: 5
Registered: February 2019
Junior Member
Sorry for the delayed response.
I checked the thread and unfortunately I don't have access to the artifacts you mention there (I am getting 403 when accessing https://ci.eclipse.org/gemini/job/gemini-web-container.snapshot/lastSuccessfulBuild/artifact/build-web-container/target/). I managed to download some of the jar files from maven central repository but I am still missing some. Could you please make the artifacts available so that I am able to download them easily and try running with them?
Best regards


Martin Zukal
Re: gemini web Failed to start component [message #1830193 is a reply to message #1830192] Mon, 20 July 2020 09:59 Go to previous messageGo to next message
Violeta Georgieva is currently offline Violeta GeorgievaFriend
Messages: 278
Registered: October 2010
Senior Member
Check this https://www.eclipse.org/gemini/web/download/
Re: gemini web Failed to start component [message #1830199 is a reply to message #1830192] Mon, 20 July 2020 11:12 Go to previous messageGo to next message
Martin Zukal is currently offline Martin ZukalFriend
Messages: 5
Registered: February 2019
Junior Member
Unfortunately I experience the same behavior also with Gemini Web 3.0.6.

Martin Zukal

[Updated on: Mon, 20 July 2020 12:00]

Report message to a moderator

Re: gemini web Failed to start component [message #1830212 is a reply to message #1830199] Mon, 20 July 2020 19:23 Go to previous message
Martin Zukal is currently offline Martin ZukalFriend
Messages: 5
Registered: February 2019
Junior Member
No Message Body

Martin Zukal
Previous Topic:OSGI extender error
Next Topic:Gemini web does not run Eclipse BIRT viwer webapp
Goto Forum:
  


Current Time: Sun Jun 13 18:57:34 GMT 2021

Powered by FUDForum. Page generated in 0.01862 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top