Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Table not Showing in Connected Oracle Database in BIRT(Remote Oracle Database Successfully Connected to BIRT But Tables Are Not Showing)
Table not Showing in Connected Oracle Database in BIRT [message #1829101] Thu, 25 June 2020 07:47 Go to next message
Linkon Ruhul is currently offline Linkon RuhulFriend
Messages: 1
Registered: June 2020
Junior Member
I have connected a remote oracle database by its IP address in BIRT through a VPN network. It shows the connection successfu but tables are not showing. Just Stored Procedure is showing there.

I have also increased the maximum number of tables in the following manner:
Windows -> preferences -> Report design -> Dataset Editor -> JDBC Dataset -> Property "Maximum number of tables"

But still, it's not working!

Is there any solution? Please help me.
Re: Table not Showing in Connected Oracle Database in BIRT [message #1831120 is a reply to message #1829101] Tue, 11 August 2020 21:30 Go to previous message
Thomas Gutmann is currently offline Thomas GutmannFriend
Messages: 21
Registered: April 2020
Junior Member
Hello Linkon,

If you have a valid connection and you can see the procedures but not the table then it sounds like an GRANT issue on your database use.

Can you select your missing tbales with your db-user with an sql developer?
Because sometimes it can be that you need additional grants of your tables for example when the table isn't an original table on your db-user.
And if it a table on another user then you need the SELECT GRANTs on it.

Kind regards
Thomas
Previous Topic:Align on Decimal Point for Negative Numbers with Parentheses
Next Topic:Using an IN clause on an integer with report parameter
Goto Forum:
  


Current Time: Fri Sep 24 19:34:34 GMT 2021

Powered by FUDForum. Page generated in 0.01628 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top