Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Linux Tools Project » Please help me(Gcov Problem)
Please help me [message #1828962] Tue, 23 June 2020 11:31 Go to next message
Myint Myitzu is currently offline Myint MyitzuFriend
Messages: 2
Registered: June 2020
Junior Member
I used eclipse mars.2, gcov plug in and MinGW compiler for coverage result of c programs.

I have encountered a problem that is 0% result of the gcov/gcda file although the program may have some percentage of coverage.
The tested C program can be compiled and run but these gcov and gcda files do not show the coverage result. Why?

So, please help me to get the coverage result.
My testing screen shoot is in the attachment.
Thanks
  • Attachment: test.png
    (Size: 189.64KB, Downloaded 12 times)
Re: Please help me [message #1828964 is a reply to message #1828962] Tue, 23 June 2020 12:00 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3882
Registered: July 2009
Senior Member

The first thing you should do is try this on the current release. Mars.2 was released in 2016.

Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Please help me [message #1828979 is a reply to message #1828964] Tue, 23 June 2020 14:54 Go to previous messageGo to next message
Jeff Johnston is currently offline Jeff JohnstonFriend
Messages: 211
Registered: July 2009
Senior Member
Nitin Dahyabhai wrote on Tue, 23 June 2020 08:00
The first thing you should do is try this on the current release. Mars.2 was released in 2016.


Yes. There have been fixes in Linux Tools concerning gcov since 2016 and the old gcov plug-in will not handle newer gcc versions as the underlying gcov data format has been changed in some releases.
Re: Please help me [message #1829017 is a reply to message #1828964] Wed, 24 June 2020 04:08 Go to previous messageGo to next message
Myint Myitzu is currently offline Myint MyitzuFriend
Messages: 2
Registered: June 2020
Junior Member
Thanks you so much for your suggestion.
I tried this on Eclipse neon 3 for CDT but the result is 0%.
Please help me, Sir!!
Re: Please help me [message #1829081 is a reply to message #1829017] Wed, 24 June 2020 20:17 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3882
Registered: July 2009
Senior Member

Neon.3 was from 2017. It is also not the current release.

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Java App in Container
Next Topic:Oprofile can not show the samples of app but just some *.so from kernel
Goto Forum:
  


Current Time: Thu Oct 29 11:46:54 GMT 2020

Powered by FUDForum. Page generated in 0.02111 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top