Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » marketplace error after fresh install of 2020-06
marketplace error after fresh install of 2020-06 [message #1828822] Fri, 19 June 2020 09:29 Go to next message
some one is currently offline some oneFriend
Messages: 1
Registered: June 2020
Junior Member
Fresh install of 2020-06 , fresh workspace, go to login to access my list of favourite plugins after not using eclipse for more than a year, and error.

Any ideas out there ?

MarketplaceDiscoveryStrategy failed with an error
Cannot complete request to https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&client.version=1.8.3.v20200522-1533&os=macosx&ws=cocoa&nl=en_US&java.version=13.0.2&product=org.eclipse.epp.package.java.product&product.version=4.16.0.I20200604-0540&runtime.version=3.18.0.v20200506-2143&platform.version=4.16.0.v20200604-0540: Invalid response content: The markup in the document preceding the root element must be well-formed.
Invalid response content: The markup in the document preceding the root element must be well-formed.
The markup in the document preceding the root element must be well-formed.
Received response begins with:

1: <!doctype html public "-//w3c//dtd html 4.0 transitional//en">
2: <html>
3:   <head>
Re: marketplace error after fresh install of 2020-06 [message #1828855 is a reply to message #1828822] Sat, 20 June 2020 04:54 Go to previous messageGo to next message
Ed Merks is currently offline Ed MerksFriend
Messages: 31959
Registered: July 2009
Senior Member
Perhaps this was a transient server problem because when I visit that URL it yields content that starts like this:
<marketplace>
  <market name="Eclipse Project" id="3891" url="https://marketplace.eclipse.org/category/markets/eclipse-project">
    <category id="6" count="5" url="https://marketplace.eclipse.org/taxonomy/term/6%2C3891" name="Editor"/>


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: marketplace error after fresh install of 2020-06 [message #1839618 is a reply to message #1828822] Wed, 24 March 2021 15:38 Go to previous messageGo to next message
Steven Schroeder is currently offline Steven SchroederFriend
Messages: 12
Registered: July 2009
Junior Member
I have the same problem, but with 2021-03:
MarketplaceDiscoveryStrategy failed with an error
Cannot complete request to https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&os=win32&platform.version=4.19: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I see the XML when I go to https://marketplace.eclipse.org/api/p?client=org.eclipse.epp.mpc.core&os=win32&platform.version=4.19 in a web browser, but Eclipse fails.
Re: marketplace error after fresh install of 2020-06 [message #1839645 is a reply to message #1839618] Thu, 25 March 2021 06:02 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 31959
Registered: July 2009
Senior Member
PKIX errors are caused by the JRE you are using to run the IDE missing the root certificate associated with the site being accessed. Updating your JRE to a newer one should help.

Ed Merks
Professional Support: https://www.macromodeling.com/
Previous Topic:simulation
Next Topic:Eclipse keeps crashing
Goto Forum:
  


Current Time: Wed Jul 28 02:17:47 GMT 2021

Powered by FUDForum. Page generated in 0.02804 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top